Saved game folder switches sporadically


SquarelyCircle
  • Branch: Live Branch Version: Windows Pending

The saved game folder used by ONI switches between two alternative folders (listed below) with no apparent reason why. Sometimes it'll start with one, then switch to the other.

Every time I start the game, I have to carefully evaluate if the game I'm looking at is the most recent saved game. If it's not, I sometimes have to go find the saved game in the other folder and copy it over.
This is really aggravating, since I have to be really cautious about starting my game, and I have no idea why this is happening.
Most of the time it'll start out showing the wrong saved game, and then update in a few seconds to the correct saved game, but sometimes it never updates.
The two save locations are in my documents (C:\Users\[username]\Documents\Klei\OxygenNotIncluded\save_files\auto_save), and in the steam app for ONI on my second hard drive (F:\Games\Steam\steamapps\common\OxygenNotIncluded\Klei\OxygenNotIncluded\save_files\auto_save).

 

On a side note (just in case it's related),my mods all disable every time I start the game, and I don't know why.

DxDiag.txt


Steps to Reproduce
Start the game. Look at the "resume" saved game listed. Or click the load button, and see what files are listed.

Status: Pending

This issue has not been confirmed by a developer yet.


  Report Bug


User Feedback


....

Hi!

From the DxDiag file, it appears that you're running on a Windows Education edition.
That means it is possible that your user profile is one that is known as a "Roaming Profile".

From looking at the way the game works, and the details we understand about roaming profiles,
it seems that your user Documents folder is temporarily unavailable from the OS. This is why it finds the 'wrong' folder.
When the Documents path does become available (from the OS), the 'right' folder is shown instead.

If you're able to, can you elaborate on the nature of your user profile?
At the very least, this information should help narrow it down for you on your end.


Thanks!

Share this comment


Link to comment
Share on other sites
....

I believe it is a local account.

I opened advanced system properties, clicked 'settings' under 'user profiles'. Then, I clicked on my account (COMPUTER\username), and clicked "change type". The roaming profile was grayed out, and the local profile was selected. There was no way to change it or even click 'ok', only 'cancel'.

So, I'm pretty sure this is local. Let me know if you think there's a possibility that I've misidentified the type of account, and how you would recommend I proceed.

Just FYI, I got the education edition as discounted software from the school, but it's installed for my own use on my own computer. It's not linked to the institution in any way, as I imagine roaming accounts usually are (I don't really know, just guessing).

Update: I just noticed that the "Status" next to my profile says "Local" as well.

Share this comment


Link to comment
Share on other sites
....

Thanks for the info.
So the curious thing then, is how it gets no result from the OS for the `Documents` folder.
(If you're interested, it gets a blank result from this function, with this type).

What's weird is that it's temporary, and then starts working again?
Could you elaborate on where/when you see that?

Do you see the filename change in the main menu?
Does the list in the load screen show the wrong files as well?
Does it resolve while the game is running, or do you restart the game to see a change?
 

Share this comment


Link to comment
Share on other sites
....

The number sometimes does update right while I'm looking at it. It'll start off with something like "Resume Cycle 1219" and then a few seconds later, it magically says "Resume Cycle 1245".

The list on the load screen also shows the wrong files, but then updates to show the correct files at the same time as the resume button does.

It resolves while the game is running, with a sudden change in the number, and no error or message at all, as if nothing happened.

Share this comment


Link to comment
Share on other sites
....

Ok, interesting!
Does this happen every time you launch the game, or only after you re-log in to Windows?
Like does it require logging out/logging in again to trigger it? Does it do it with a sleep/log out, or only on a full restart/shutdown of Windows?

And another angle, if it corrects itself to the right folder while running, what does restarting the game show?
If you restart the game, does it still see the correct path or does it happen every time?

And finally, is it possible you moved your documents folder, or it comes from a network or network drive somehow?
Just trying to narrow down the possibilities here.

Thanks!

Share this comment


Link to comment
Share on other sites
....

It doesn't require logging out/back in to trigger. Just restarting the game is enough (and the mods all turn off, too, including the "enable all" mod that's not supposed to get disabled).

So, I quit the game. Restart the game. Problem exists.

My documents folder is on a different drive than my game, but has not been moved. The documents folder is on my C drive, my game is installed on my F drive. However, neither is a network drive.

Thanks for helping me figure this out. Sorry that my answers aren't more enlightening.

Share this comment


Link to comment
Share on other sites
....

No worries!
Thanks for the info.

I have one thing you can try that might help but might not: Try navigating to the documents folder in Windows Explorer, manually, before launching the game. Though you said it happens each launch, I'm not sure this will help, but maybe it will 'activate' the documents folder more consistently so you can more easily get the right save.

The tricky thing is this issue doesn't seem to make any sense.
We'll keep looking into it on this end but if you gain any more insight, or have any more info, please let us know!

 

  • Thanks 1

Share this comment


Link to comment
Share on other sites
....

Nope, doesn't help.

Starting the game this time, it isn't updating to my latest save at all, after maybe 10 minutes of waiting. So, I'll be copying over the save file.

 

O2 wrong save.png

On a separate note, I moved the game to my SSD C: drive. Doesn't seem to have fixed it.

Share this comment


Link to comment
Share on other sites
....

I've got new info!

I've confirmed that there are two mods folders, similar to how there are two saved game folders. By installing (but not turning on) the non-steam mod "automapsharing" from toolsnotincluded.net, I discovered that the mod only existed in the mod list half the time, depending on which folder the game is using for my saves/mods.

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now