Research screen too big for Macbook


MadameHardy
  • Branch: Preview Branch Version: OSX Pending

The new broader spacing and (more important!) limited zoom for the Research screen makes it almost impossible to use on a laptop screen.   First screencap is the results of a search; second is normal screen zoomed out as far as it can be.  Both of these are the full screen.

The newly-added whitespace between individual panels makes scrolling time-consuming.  It's painful when you're trying to remember (say) where the automation wire is.   Please bring back full zoom, and/or reduce the white (technically blue) space!

Screen Shot 2019-07-23 at 4.31.21 PM.png

Screen Shot 2019-07-20 at 4.09.27 PM.png

Screen Shot 2019-07-25 at 9.31.17 AM.png


Steps to Reproduce
Run ONI on a Macbook Pro Retina, Mojave 10.14.5 Note: I can't upload my player logs, because the log files chooser doesn't let me upload a log with the extension .log.


User Feedback


I agree that they should allow the research screen to be zoomed out a lot further -- ideally far enough out that you can see the entire vertical area in the current window.

As a workaround, you can temporarily go into Options > Graphics > Interface and set UI Scale to 75% to see a bit more of the tree.

 

Share this comment


Link to comment
Share on other sites

This bug isn't mac specific. The research screen is bugged on 4K windows displays as well. There are several bug reports about it. It seems to be linked to UI scaling.

 

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now