Sign in to follow this  

Priority setting from the build menu does not apply when you build replacement pipes or wires


DotNet
  • Branch: Live Branch Version: Windows Fixed

When I want to replace or upgrade my normal pipes (gas and liquid) to insulated or radiant pipes, I will choose the new pipe type from the build menu and directly place on top of the existing pipes.

But the problem is, no matter what priority is set in the build menu, the actual priority applied to the scene is always 5.

Ok although I can still change the priorities in the priority screen afterwards, but this is annoying.

The same problem occurs when replacing normal wire / conductive wire / heavy wire.

P.S. It seems that I cannot just replace the pipes with different materials of the same type (e.g. replacing normal pipe of Granite to normal pipe of Igneous). I don't know if it is bug? Because I can replace solid tiles with different materials of same type...


Steps to Reproduce
Prepare some normal pipes in the scene, choose the insulated pipe from the build menu and set the priority to 9, place the new pipes on top of the existing normal pipes, open the priority screen (P) to see the build priorities that applied to the new pipes, and they show 5.

Status: Fixed

This issue has been fixed in either a future version or updated in a previous version.


  Report Bug
Sign in to follow this  


User Feedback


A developer has marked this issue as fixed. This means that the issue has been addressed in the current development build and will likely be in the next update.
.... ....

Changed Status to Fixed

Both issues have been addressed for a future patch (not in the current preview build, however)

  • Thanks 1

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now