Sign in to follow this  

Massive RAM usage, possible memory leak


Crayons
  • Branch: Live Branch Version: Linux Pending

Oxygen not Included tends to use extreme amounts of RAM over a longer period of time. I'm using a Linux environment with 16 GB of RAM with another 17.2 GB of SWAP space(RAM on disk/ pagefile on windows if I'm not mistaken). My system nearly hard-locked multiple times because all of that was being used only by the game. In itself, the OS consumes AT MOST 1.5 GB of RAM.

Problem is, normally, if I play for 2 hours, save a couple of times, load a couple of times... and then I return to the home menu, closing my world, I should have the same RAM usage as if I just opened the game, but that is not the case here. The game keeps reserving more and more and more RAM as I play, without freeing it, and thus leading to a system crash sooner or later if I do not restart the game.

I have tested on a survival world with 500 cycles and a sandbox world with... a couple of cycles. Both will make the game hog all of the RAM at a different pace/timeframe.

I tried running with no mods, same effect, but the RAM was hogged at a slower pace (which means more load/save cycles were needed to fill my memory), I believe the log files have recorded my attempt.

I honesly have no idea what other technical is needed, I will be keeping an eye on replies, so if anything is requested, I'll provide it as soon as possible.


Steps to Reproduce

Play any world, no matter size or cycles; save/ load a couple of times and generally just play the game, watch the whole OS jam before your eyes.

Sign in to follow this  


User Feedback


Apologies for not looking for duplicates enough.
I do realize that it is really really hard to fix but... Welp, the only thing we can do is wait.

Share this comment


Link to comment
Share on other sites

I started having this same issue yesterday. Ubuntu Linux, nvidia GTX 1060, runs all my other games fine at a nice framerate. ONI hard-crashed yesterday, and now if I play for more than 3-4 minutes, framerate drops a LOT. I quit before getting another hard crash, but I assume that's what would happen.
Where could I find logs or something like that to help get the bug looked at?

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now