Sign in to follow this  

Liquid solidifying into existing debris gets wrong temperature.


wachunga
  • Branch: Preview Branch Version: Windows Fixed

When a liquid solidifies in a cell that already contains a pile of debris, the now bigger pile doesn't calculate it's new temperature properly. Instead it maintains it's old temperature.

image.thumb.png.973dd937035f9c10e74a6247f0c63381.png

image.thumb.png.d3998ee87057ae2013c751551208a7f8.png

In both scenarios there was a small pile at 400C prior to the doors opening.

In the first screenshot right side, the liquid falls as the droplet animation and does not interact with anything until it lands on the metal tile. It instantly solidifies and adds to the existing pile. The pile stays at 400C even though more and more hot material is being added to it.

In the second screenshot left side, the liquid falls as a blob and solidifies before hitting the metal tile. This makes a falling debris pile which adds to the existing pile. This new pile has it's temperature calculated correctly (or at least it appears so).

 

Drip Debris Bug.sav


Steps to Reproduce

Load save, flip both switches, unpause, observe temperatures of the two piles.

  • Like 1
  • Thanks 3
Sign in to follow this  


User Feedback


A developer has marked this issue as fixed. This means that the issue has been addressed in the current development build and will likely be in the next update.

Update to add a different style of test demonstrating the bug. Shamelessly stolen from @ghkbrew's debris furnace.

image.thumb.png.c1ebb86292e83f45a87752820ac9ca74.png

image.thumb.png.05b5dd7faba94fdd3e7968268844ee7b.png

Super cooled molten lead falls either as the drip animation or as a bead. When as a bead, the molten lead solidifies in mid air forming a falling debris pile. When as the drip animation, the molten lead solidifies directly on top of the insulated tile where the existing pile already sits. Both piles started as 1kg @ 300C. The bead pile quickly lowers in temperature as new cold lead is merged with it. The drip animation pile incorrectly stays at 300C.

 Load save, flip switch, unpause, and observe the pile temperatures.

Drip Debris Bug 2.sav

Edited by wachunga
  • Like 1

Share this comment


Link to comment
Share on other sites

Changed Status to Fixed

This is currently fixed in Spaced Out and will be fixed in the base game when we merge the codebase. 

  • Thanks 2

Share this comment


Link to comment
Share on other sites

This still seems to happen as of build U37-484114-5. In the attached save there is 666.9kg of gold debris at 24.9C in a tile of 25.6kg of liquid gold at 1363.5C in the water (on the left of the gold volcano platform). On the next tick, the liquid gold solidifies and the result is 692.5kg of gold debris at 25C. 

bug.sav

Share this comment


Link to comment
Share on other sites

Can confirm still a bug in 486708.

20211120115426_1.thumb.jpg.2f07b4b83e8c8399c5afe34e742b16c8.jpg

20211120115436_1.thumb.jpg.336fb02ae6dc516a8b4ef5ea128b2479.jpg

20211120115501_1.thumb.jpg.40491bdef00afaa1b162696421f685ac.jpg

20211120115505_1.thumb.jpg.2416fe28ec91ae0d88879456a95cfaf5.jpg

 

First 2 screenshots show before condition of 100kg 1409.9C magma/igneous falling into 100kg 409.9C igneous. Last 2 screenshots show magma solidified and incorrectly took temperature of existing debris while igneous fell and combined correctly with existing debris.

debris solidification bug.sav

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now