liquid pipe doesn't run water


dipharoh
  • Branch: Live Branch Version: Windows Pending

hello klei

i love oxygen not included but i am facing a bug that i think will stop me from playing

after a not short time of working fine for some reason liquid pipes didn't run water. it doesn't say pipe broken. water just stops and doesn't flow at a point in the pipes

here i posted screenshots and save files

the first screenshot and save file has the pipes let water flow in a direction and not the other

the second screenshot and save file has the pipes not flowing water

 

 

 

1_Edited.jpg

1.sav

2_Edited.jpg

2.sav


Steps to Reproduce
i am not sure how it happened. it was working fine for quite a long time

Status: Pending

This issue has not been confirmed by a developer yet.


  Report Bug


User Feedback


....

to fix these issues build like this branch out every infeed and outfeed,

also either have 1 infeed and x outfeed on a line or reverse. or cluster the infeed together let it all go over 1 line and then let it go to the clustered oufeed but that didn't happen in your build so maybe you know.

457140_20180711112316_1.thumb.png.69cf00b9b8737f5386b023a72976245a.png

I don't know if it's a bug or a design choice to spare cpu but the problem can easily be avoided.

good luck

Share this comment


Link to comment
Share on other sites
....

Moonshade thank you for caring about my problem

but i don't think i understand everything you said

do you mean i should build sidebranches of intakes?

that's what i did in my second save and still the water stopped somwhere in the pipes

and did you look at my first save ain't the water suppose to run in both sides up and left. why does it flow only left??!!

Edited by dipharoh

Share this comment


Link to comment
Share on other sites
....

I put one liquid bridge on your piping, and it's working again.

Screenshot_7.thumb.png.c50688613ded7237a764c1e3f2def8fb.png

 

When the pipe contents lost his way, guide them. Because there is always a limitation on everything. I hope klei do something, but even with increased path detection limit, there is always a limit. And increased detection limit means increased load on our engine, meaning heavier lag (specially with huge base).

Share this comment


Link to comment
Share on other sites
....
18 minutes ago, abud said:

I put one liquid bridge on your piping, and it's working again.

Screenshot_7.thumb.png.c50688613ded7237a764c1e3f2def8fb.png

 

When the pipe contents lost his way, guide them. Because there is always a limitation on everything. I hope klei do something, but even with increased path detection limit, there is always a limit. And increased detection limit means increased load on our engine, meaning heavier lag (specially with huge base).

WOW Working!!!!!!

Thank You abud

and i hope Klei do something about this

Share this comment


Link to comment
Share on other sites
.... ....
Quote

the first screenshot and save file has the pipes let water flow in a direction and not the other

You mean why water flow in the bridge, but not up to showers? That's what people called bridge priority. When there is a bridge or valve, they will prioritize that over the normal way. On the other hand, when from bridge merge with a normal line, the bridge will wait.

Let's say there is water flowing from left

Screenshot_7.png.42159ac43596ac31a8df80c0f18da1e2.png

In the picture above, water will go up until upline full then continue to the right side.

Screenshot_8.png.62a79755d18d18b17d806f753272614a.png

In this second picture, water from the top cannot make his way to the right unless he can merge with water from the left side or line clear.

 

These bridge and valve behavior are intended like that, so we can manipulate which one we want to prioritize.

 

edit: Sorry that I skip the first problem before. I see nothing wrong there, just need some understanding of how those bridges work. And I'm not good at explaining things.

 

Edited by abud
  • Thanks 1

Share this comment


Link to comment
Share on other sites
....

that bridge priority info solved my problem 

thank you abud you are the best

a million kisses from egypt to you

Share this comment


Link to comment
Share on other sites
....


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now