Linux - unreadable notification, load leads to black world


der_teilnehmer
  • Branch: Live Branch Version: Steam Fixed

Hi there,

I was very happy when ONI came to Linux and bought it right away. Nice job, Klei team, thanks for thinking of us even though we're a small audience as of now.

The game starts nicely, I can choose characters and the loading screen displays correctly. All text up to here is legible. After that, I get a message that has unreadable text.

5a1eb90333cc0_Bildschirmfotovom2017-11-29143939.thumb.png.b72840fa7099b0c1444f726c4e7e6dbd.png

Clicking on the right button exits immediately, clicking on the left button brings up another notification. Clicking the button here exits the game.

5a1eb8fe77f64_Bildschirmfotovom2017-11-29143950.thumb.png.5ef9019ba9a84ccde2a4de8097818b36.png

I can then restart the game and have an active savegame to continue. If I do that, it seems to load okay, I get a brief flickr of the world visible as it should be, and then the world goes black (UI remains visible though).

5a1eb9ba14ac8_Bildschirmfotovom2017-11-29144411.thumb.png.28c4f2520e852b39e9ddc51bd78bd81a.png

I'm on a Linux Mint 17 machines with all updates (Kernel 2.2.16). I use an NVIDIA GTX 750 with the recommended driver 384.

 

I assume it's a graphics issue. I'd gladly provide more insight, but dmesg doesn't yield any errors and I'm not sure where I could find them... I also assume this is normal infancy for the Linux version and will patiently wait. :) I hear others are already playing it, so it must be some version hiccups or something like that.


Steps to Reproduce
Install and start game on a machine with Linux Mint 17 and an NVIDIA GeForce GTX 750.


User Feedback


A developer has marked this issue as fixed. This means that the issue has been addressed in the current development build and will likely be in the next update.

Oh, I found where to find and include error messages - in ~/.config/unity3d/Klei/Oxygen Not Included/Player.log

Allrighty. This looks like a possible culprit:

vertex shader
0(4) : error C0202: extension OVR_multiview2 not supported

Player.log

Share this comment


Link to comment
Share on other sites
31 minutes ago, der_teilnehmer said:

Oh, I found where to find and include error messages - in ~/.config/unity3d/Klei/Oxygen Not Included/Player.log

Allrighty. This looks like a possible culprit:

vertex shader
0(4) : error C0202: extension OVR_multiview2 not supported

Player.log

Thats a false positive, I have the same error messages but the game works fine for some reason. I'm also on linux mint but 18.3 and HWE kernels. However there is another player with issues and he also have an nvidia card so it might be related somehow. If you're using a intel CPU with a directx 11 graphics chip try using that and see if anything's different.

You might also need to start a new game cuz that save might be broken. Also if you crashed the game again upload that log before playing again.

Edited by AlexRou

Share this comment


Link to comment
Share on other sites

The same happens with Xubuntu 16.04.

This kind of bug happens with some unity based games - Kerbal Space Program has the same bug in linux, and setting LC_ALL=C Solved the problem too. 

The possible cause is, when unity load text files (like the yaml used in ONI, or the CFG used in kerbal, it parses them using the currently configured system locale - some languages the float point separator is the comma character (,), other is the point character (.). A possible coding solution is simple: Just pass the encoding parameter when the text file is loaded (Encoding.ASCII, for instance).

I am not a Unity developer, but i do program with Mono C#, python, C, C++... and this kind of problem appears in my life frequently :(

Share this comment


Link to comment
Share on other sites
On 30.11.2017 at 9:11 AM, der_teilnehmer said:

Thank you everyone for chiming in! Indeed, entering 'LC_ALL=C %command%'

The proposed workaround works for me too.  Just for reference, I had to start a new game. Choosing the 'continue' option after changing the command line would still lead to a black world.

Cheers!

Share this comment


Link to comment
Share on other sites

This issue should be fixed in an upcoming update. If you'd like to get the fix before it's released on Dec 14, you can try it out by switching to our testing branch following the instructions here: 


 

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now