[Linux] Block on word generation


Bordaste
  • Branch: Live Branch Version: Steam Pending

Hi guys,

I've just download the game under my Debian Jessie (4.9.0-0.bpo.3-amd64 #1 SMP Debian 4.9.30-2+deb9u5~bpo8+1 (2017-09-28) x86_64 GNU/Linux). 

During the first try of world generation, and during all others, the screen block (before dupe selection) on "Generation world, Oh dear let's try this again 0.0"

I attach my log find in ~/.config/unity3d/Klei/Oxygen Not Included/Player.log

Let me know if you need anything else.

Thanks


Steps to Reproduce
Create new world

Status: Pending

This issue has not been confirmed by a developer yet.


  Report Bug


User Feedback


....

Same issue exactly for me, in the same exact conditions.

I'm running on Ubuntu 16.04.1 with kernel 4.10.0-42-generic. Steam client, nvidia pilots and systems are up to date.

I have also appended an excerpt of the Player.log file showing repeated errors in world generation of the following type:

ERROR: Unknown char: .
  at System.Double.Parse (System.String s, NumberStyles style, IFormatProvider provider) [0x00000] in <filename unknown>:0 
  at System.Single.Parse (System.String s) [0x00000] in <filename unknown>:0 
  at ProcGen.WorldGenSettings.GetDefaultFloat (System.String target) [0x00000] in <filename unknown>:0 
  at ProcGen.WorldLayout.GenerateOverworld (Boolean usePD) [0x00000] in <filename unknown>:0 
  at ProcGenGame.WorldGen.GenerateLayout (ProcGenGame.OfflineCallbackFunction updateProgressFn) [0x00000] in <filename unknown>:0 
 
(Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

 

excerpt-Player.log

Share this comment


Link to comment
Share on other sites
....
5 hours ago, h3dg3h0g83 said:

ERROR: Unknown char: .

I don't have linux and have no idea how it works, but in some parts of the world (like where I live) is as decimal separator used comma like 1,23 instead of 1.23

So it might be the case that some system "string to number" methods expect comma instead of dot in your cases.

ONI should be able to deal with it but maybe you can try to temporary change your system to use dots as decimal separators?

 

Share this comment


Link to comment
Share on other sites
.... ....

Well done!

That perfectly work for me.

Thanks a lot! 

PS: I wonder why the game don't lanch by default with 'LC_ALL=C %command%' option...

Share this comment


Link to comment
Share on other sites
.... ....

Hey guys,

Same bug here, I'm on Ubuntu 16.04 (4.4.0-59-generic #80-Ubuntu SMP x86_64) with the latest version of oxygen not included (just bought it) :

Quote

ERROR: Unknown char: .
  at System.Double.Parse (System.String s, NumberStyles style, IFormatProvider provider) [0x00000] in <filename unknown>:0
  at System.Single.Parse (System.String s) [0x00000] in <filename unknown>:0
  at ProcGen.WorldGenSettings.GetDefaultFloat (System.String target) [0x00000] in <filename unknown>:0
  at ProcGen.WorldLayout.GenerateOverworld (Boolean usePD) [0x00000] in <filename unknown>:0
  at ProcGenGame.WorldGen.GenerateLayout (ProcGenGame.OfflineCallbackFunction updateProgressFn) [0x00000] in <filename unknown>:0
 
(Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

 

Can we have an update please?

Share this comment


Link to comment
Share on other sites
....
38 minutes ago, skhaen said:

Hey guys,

Same bug here, I'm on Ubuntu 16.04 (4.4.0-59-generic #80-Ubuntu SMP x86_64) with the latest version of oxygen not included (just bought it) :

 

Can we have an update please?

Did you not see the link I pasted above? That's the fix. 

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now