Infinite power loop - Transformer attached to empty battery


mathmanican
  • Branch: Live Branch Version: Linux Fixed

The build below seems to push 3kw of power from two batteries (one battery is empty, the other has power), while only draining 1.5kw. Here is a save file with the build premade. The Contagious Trainwreck.sav

5c70064d65a02_Screenshotfrom2019-02-2121-57-52.thumb.png.36d82375757f1c891614681b3d927c9e.png

5c70064f4b375_Screenshotfrom2019-02-2121-58-58.thumb.png.dcaacfa1c14f829d6093557468f77ebe.png

Replacing the 6 small transformers with 10 big transformers means you push 20kw while only draining 10kw.  The extra power can be siphoned off with whatever system you want. Free infinte power. Kinda silly and game breaking if you create this.  Here's the attached general forum post. 

 

 


Steps to Reproduce
Build system above. Prime it with a manual generator or any other generator. Then delete the generator and use free power forever.

Status: Fixed

This issue has been fixed in either a future version or updated in a previous version.


  • Like 1
  • Thanks 6
  Report Bug


User Feedback


A developer has marked this issue as fixed. This means that the issue has been addressed in the current development build and will likely be in the next update.
.... ....

I don't understand this mechanism exactly.
But when I connected two or more transformers in series,
it had a bug that combined the power grid after the second.
(ex. connect 1KW(A)'s output and 1 KW(B)'s input, then 1 KW(B)'s output can use 2 KW.)
These other power grids were connected, it makes this problem.(maybe)

IE.gif.d68cbdf8a884c2084d350b74a9e0075e.gif

 

It's not exactly the same as the writer's, but it works too.
It was very very very fun so I made it an animation.
Have a fun weekend.

  • Like 1

Share this comment


Link to comment
Share on other sites
....

Here are two more bug reports that may be connected to this bug. I think it definitely is the same as the first one below (just the looping power back on itself removes the need for a single generator to run). The second bug post is really old, and may or may not be the same. 

 

Share this comment


Link to comment
Share on other sites
....

Here's a post on reddit where they explored this more, and added extra details with animated gifs showing exactly what is going on. 

 

Share this comment


Link to comment
Share on other sites
....

Here is a more detailed explanation of what I believe the bug is, as well as how to compute exactly the power gained from. 

 

 

Share this comment


Link to comment
Share on other sites
.... ....

Changed Status to Fixed

The primary issue will be resolved in the next hotfix. If you find further power/battery issues, please feel free to start new bugs! :) Thanks again for all the data in this report.

  • Thanks 1

Share this comment


Link to comment
Share on other sites
....
8 hours ago, Ipsquiggle said:

Changed Status to Fixed

The primary issue will be resolved in the next hotfix. If you find further power/battery issues, please feel free to start new bugs! :) Thanks again for all the data in this report.

Ask and you shall receive:

 

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now