Graphics severely broken after macOS Catalina update


DarthVader1
  • Branch: Live Branch Version: OSX Known Issue

Hey people!

Last Wednesday, I installed the new macOS Catalina and since then, ONI is severely broken (see image below).
 
The picture first let me think of a GPU failure. However, no other Steam game shows this behavior, neither does the Heaven Benchmark on Preset extreme (It runs below 20 fps, but it definitely should stress the GPU enough to show any hardware failure).
Geekbench also runs fine (CPU, as well as GPU computation).
 
I am running macOS Catalina 10.15 on a MacBook Pro 2017 with an i7-7820HQ, Radeon 560 4GB, and 16GB DDR3 RAM.
 
It’s the latest steam version as well as the latest ONI version. Both were freshly installed after the OS update.
 
Help! I had an accident and broke my wrist and ONI is one of the very few things I can do :(

IMG_0071.jpeg


Steps to Reproduce
Happens consistently when starting the game.

Status: Known Issue

We are aware of this issue and have it logged internally but either we do not have a fix ready yet or we are not planning on addressing the issue in the immediate future.


  Report Bug


User Feedback


....

Take it out of full-screen mode. It may be a pain to do so but that should at least allow you to play the game.

Share this comment


Link to comment
Share on other sites
....

I have the same issue, the game ran well before I updated to Catalina and now I have severe gfx tearing. The tearing is soo bad that I can not change to windowed mode... 

Share this comment


Link to comment
Share on other sites
....
18 hours ago, Grymnar said:

I have the same issue, the game ran well before I updated to Catalina and now I have severe gfx tearing. The tearing is soo bad that I can not change to windowed mode... 

Press cmd+tab. It’s indeed a full screen issue and when tabbing through apps, it kinda gets taken out of the full screen. The tearing stops and you can navigate through the menus.

Share this comment


Link to comment
Share on other sites
....

Same issue here.  I found that if i played around with the mac resolution outside of the game while it is running (using RDM) I could sometimes get it to behave, but haven't found repeatable steps to doing that yet.  Like changing from 1680x1050 hiDPI to 1680x1050 not hiDPI and back flipping from desktop to full screen game a few times and eventually got it to show clearly. Might have more to do with the switching desktops than the resolution...who knows.  This is on a 2018 MBP freshly updated to Catalina.  

Share this comment


Link to comment
Share on other sites
....

Changed Status to Known Issue

Thanks for the bug report; we're looking for a solution to this!

  • Thanks 2

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now