Sign in to follow this  

Gas Vents are overpressurized. Always.


JonathanSmith
  • Pending

Even when they're first built in a new spot they're overpressurized. If you disassemble them and replace them, overpressurized. I cannot keep them running for five minutes without them becoming permanently overpressurized.

overpressure.png


Steps to Reproduce
Build a vent.
Sign in to follow this  


User Feedback


.... ....

It's not a visual bug.
They are over pressurized.
They are working too though.
The reason is that they are toggling quickly between working and not.
So the icon just stays there.
This is because your pump and vent are in the same area.

Share this comment


Link to comment
Share on other sites
....

They're like this whether you have a valve or not, and temperature doesn't change when pumping out 5C air. It's not a visual bug, they simply are not working. I don't know if they're not working because they are overpressurized or whether there's two bugs interacting, but I can say with certainty that something is very wrong with the vent functionality.

I can even have air going _into_ a vent and just disappear, again not changing the gas composition or temperature at the output.

Share this comment


Link to comment
Share on other sites
....

The easiest testcase, build a vent and tightly wall around it. pump gas into that vent. When the small room gets saturated with air (every tile around 1000-1500g) it will be truly overpressured and the gas will be increasing in the vent storage and then in the pipe.

 

And the testcase for the visual bug, build a vent, disable it, pump 10kg gas in it, enable the vent.

Since it cant output the 10kg gas at the same time, it will get the overpressure icon but the vent will constantly output the air, and as the gas spread the vent can go down to empty easily. (you can turn off the pump) But since its a visualbug the icon will stay there even if the vent empty.

Share this comment


Link to comment
Share on other sites
....

You seem to misunderstand. I'm well aware that the icon is bugged. The VENT stays overpressurized all the time. Does not exhaust air. Nada. Kaput. Pipes accumulate gas. No gas leaves. I can deconstruct at least back to the valve itself, rebuild and it gas still just reaccumulates in the pipes, 10g at a time.

 

It. Is. Busted.

Edited by JonathanSmith

Share this comment


Link to comment
Share on other sites
....


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now