Game running significantly slower


strideknight
  • Branch: Preview Branch Version: Windows Pending

I'm sorry this isn't a specific 'bug', but more like a general thing I noticed.  Basically, before the optimizations you guys made in the last couple updates, the game used to barely run - couldn't have more than 8 dupes and once infrastructure got too big, I'd be reduced to the horrible 20fps or something.  Then you guys did the last update, OC and tubular were fantastic - I was running 24 dupes to 500-600 cycles and still in the high 40s fps.  Now, I'm back to running 10 dupes at cycle 100 and I'm dipping into the low 30s fps again.

Honestly, it makes the game completely unplayable.  I have barely done anything at this point in the game, just setup my inner base and some water supply, and its already running so much slower that I don't want to keep playing.  The hangs and microstutters constantly kill the enjoyment.

So I'm not sure if it's the way the new priority system is slowing everything down (bring back the old priority system!) or if there are optimizations that need to be performed again, but right now it's basically unplayable:(  I'm not running a slouch computer either, it's an i7-3930K OC'd to like 4+GHz with 16gb of ram.  

SpaceHole 412.sav


Steps to Reproduce
Run the game, build big base, watch game run super slow


User Feedback


....

The preview builds (e.g. the Ranching preview) run with extra debugging turned on to make crash reports more useful during this period. Unfortunately this has a significant impact on performance, so for the duration of the preview it's going to run this way. When the Ranching Upgrade goes live next week, we turn off the extra debugging and the game will go back to running normally. After that if it's still running slow, please let us know right away!

And thanks for this report this in any case, we're glad you took the time. :)

Share this comment


Link to comment
Share on other sites
....

Honestly, thats great news and I'm glad to hear.  I wondered if it might be something like that, but I did want to mention it in case it was unintentional ya know.  Thank you very much for taking the time to reply to me and I'm looking forward to the actual release!  

Share this comment


Link to comment
Share on other sites
....

This slow down is far more significant than all other previews.  I've played them all and this is the first time I've had stop because it's unplayable.  At cycle 150.  

Edited by Luthage

Share this comment


Link to comment
Share on other sites
.... ....

Cycle ~350, 14 Dupes => Savegame loading => 12 FPS

After 1 Hour => 7 FPS. Yay.

When the game saves, I have 1 FPS :? I think, i need a break till the release. Not funny at the moment.

Share this comment


Link to comment
Share on other sites
....

I just picked up the game again last night after 6+ months. It's ridiculously slow. I get 12-24 fps, with dips below 1 fps at moments (especially the start of a day -- which, after reading this thread, sounds like is due to autosave). All this while Task Manager says it's using 8% of CPU and the rest of the system is mostly idle.

After day 20ish it went up to ~40fps, but still varies up and down enough to cause noticeably jerky animations.

I'm using Steam, mainline release ("Betas" says "NONE - Opt out of all beta programs"), Windows 10 PC with 64G RAM, an i7 CPU @4GHz. I have an NVIDIA GeForce GTX 980 Ti with G-SYNC enabled. 

2018-03-29 21.21.32.jpg

Share this comment


Link to comment
Share on other sites
....

...and by day 100 it's down even further, to 10-16 fps most of the time, on all speeds. With frequent jerkiness and occastional de-bursts down to the single digits.

 

Share this comment


Link to comment
Share on other sites
....

New info: I just disabled all the useless (to me) streaming/capturing services that NVIDIA installed and set to run on startup as part of GeForce Experience. I also moved my game installation from my HDD to my SSD, and set it to full-screen instead of fullscreen-windowed. It's running much more smoothly now... not sure if I can say it's solved yet.

See these links:

https://forums.geforce.com/default/topic/977238/how-to-stop-geforce-experience-from-autostarting-every-time-you-turn-on-your-computer/

https://www.ghacks.net/2015/12/27/disable-nvidia-streamer-service-to-improve-video-card-performance/

 

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now