Game keeps crashing at random


quicksilver3945
  • Branch: Live Branch Version: Windows Pending

Game seems to be crashing at random sometime since the big merger update (I know their have been a few bug fix updates since but I haven't played since last week sorry :oops:) I'm trying to go through anything I've updated since last week and the only things that stand out were:

AMD Chipset driver update (version 2.17.25.506)

https://www.amd.com/en/support/chipsets/amd-socket-am4/x570

Windows update

https://support.microsoft.com/en-us/topic/july-13-2021-kb5004237-os-builds-19041-1110-19042-1110-and-19043-1110-ae798d3c-3de3-4c1f-b9d9-7391b71da889

Neither update mentions anything that really stands out with what the player.logs are showing but I'd consider myself only.....above average? (maybe?) when it comes to diagnosing issues like this.

Most of the crashes happen just after the Klei logo appear but sometimes I am able to get through and play for a few minutes before it crashes? freeze? it just goes to a blank white screen. Task manager does not list the program as unresponsive until I try to close the ONI window.

When the crashing occurs both of my monitors go dark for a moment (almost like when do a graphics driver update?) and when it comes back ONI is all white and unresponsive. Other open programs such as chrome or steam on my other monitor do not appear to have any issues after the screens come back.

I did try to search around google/reddit to see if there was any obvious fix I could find but searching "d3d11: failed to create staging 2D texture" or "d3d11: failed to create buffer" appeared to be a little too generic to find a common cause. Some example results are below (not sure if helpful so I'll just link the two with the most detail I found quickly)

https://github.com/Unity-Technologies/ml-agents/issues/1010

https://forum.kerbalspaceprogram.com/index.php?/topic/193125-d3d11-failed-to-create-2d-texture-shader/

My PC has the following specs (sorry if not enough or too much info)

Ryzen 5900x

RTX 3080 

32GB memory

2 x 1TB nvme SSDs (1 is a samsung 980 pro and the other is a samsung 970 pro)

Running windows 10 pro version 21H1 (OS build 19043.1110)

I'm going to try to reinstall the graphics driver first and see if that helps. if not i'll try a system recovery at a later date if the issue is still occuring (it's late and it's hard to do during the work week :distress:)

 

Player.log Player-prev.log DxDiag.txt


Steps to Reproduce

Issue happens at random but most often after the Klei logo appears during startup



User Feedback


im guessing this issue is related with this autosave, when game crashes after that

i to read those unity posts and one poped up from there right away as i seen . png missing myself

Quote

 

@mmattar I followed this suggestion https://forum.unity.com/threads/d3d11-failed-to-create-2d-texture.392286/ and now the error is not coming up.

d3d_err

Resource.UnloadUnsedAssets() followed GC.Collect() does the trick, but is that a feasible solution?

 

 

easiest solution probaply is get rid off this png screenshoot after autosave

Edited by gabberworld

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now