Game hangs at logo screen after hard reset


AdmiralDimAug
  • Branch: Live Branch Version: Windows Pending

Running on Windows Ultimate 64 all updates / 16 Gb RAM / Game has no active mods.

Game hangs forever during Klei Logo screen.

1) Bought Steam stable version 4 weeks before official release (build number ??).

   App worked as expected.

   Had 2 out of memory crashes that killed the OS (hard reset required)

   Let resource manager run in background and restarted app at 10Gb threshold.

   (200 - 300 Mb memory leakage per loaded game !! C'm on guys.)

2) Automatic update (Steam) to official release build.

    App worked as expected.

    Started a new game with custom world seed after about 2 to 3 hours (game) uptime.

    (Forgot to take an eye onto memory usage.)

    Again a crash that killed the OS (hard reset required / possibly out of mem)

    On restart game hangs at logo screen.

3) Saved data files via Steam and uninstalled completely.

    Reinstalled and recovered data files.

    Without effect, the problem remains.

Thanks for making a great game with an just excellent UI, just a pitty i can't play anymore.

 


Steps to Reproduce
See above. This isn't an easy to reproduce error because a hard reset may cause unpredictable behavior even facing a journaling file system. You could try to force an out of memory error by loading saved games until the app crashes. On a developer machine this may take a while (use some memory eater utility), but that not necessarily must lead to the same results. Maybe there is just some undeleted lock file ? An output log is not available. A save file can't be available. DxDiag info appended.


User Feedback


How often do you guys reload the savegame? And when it comes to the stop, how long did you wait for the task manager co come up? I such events, (100% out of memory) windows can take up to 10 Minutes to respond to commands. 

Share this comment


Link to comment
Share on other sites

With the old version of the game Printing Pot content was randomized at game stat load times. As a beginner  I often reloaded

a single saved game 10 to 20 times to get the dupes I wanted or to get certain care packages. This feature was removed,

possibly for good reasons.

The game had memory leaks even when just loading an initial saved  game. Just press the pause key, let it run for a few hours

and watch it's virtual memory consumption. Possibly an error deep down the serialization / deserialization road.

 

I know that windows uses about 1Gb for mem tables, I didn't know it can take up to 10 minutes to recover from out of memory

conditions, never had that before.

 

I finally found the output_log.txt file. Under Win 7 it's under "C:\Users\game\AppData\LocalLow\Klei\Oxygen Not Included".

Here is an excerpt:

[19:08:21.931] [1] [INFO] Starting up with a resolution of 1600x900 @60hz (fullscreen: True)
[19:08:21.933] [1] [ERROR] Fatal parse error in C:\Users\game\Documents\Klei\OxygenNotIncluded\kplayerprefs.yaml
(Line: 1, Col: 1, Idx: 0) - (Line: 1, Col: 2, Idx: 1): While scanning for the next token, find character that cannot start any token.
Fatal parse error in C:\Users\game\Documents\Klei\OxygenNotIncluded\kplayerprefs.yaml
(Line: 1, Col: 1, Idx: 0) - (Line: 1, Col: 2, Idx: 1): While scanning for the next token, find character that cannot start any token.
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug.bindings.h Line: 43)

NullReferenceException: Object reference not set to an instance of an object
  at KPlayerPrefs.HasKey (System.String key) [0x00000] in <filename unknown>:0 
  at GraphicsOptionsScreen.SetResolutionFromPrefs () [0x00000] in <filename unknown>:0 
  at LaunchInitializer.Update () [0x00000] in <filename unknown>:0 
 
(Filename:  Line: -1)

These lines are repeated over and over again.

I've no knowlegde on Yaml, but opened "kplayerprefs.yaml" with an text editor. It's content are NULLs, means binary zeroes.

I can't say, if this is meaningful to the problem. No furthrer ideas, thank you.

 

Share this comment


Link to comment
Share on other sites

As a general rule: avoid loading games over and over. I understand one would load, if something goes wrong and one wants to avoid this.

But it has been proven faster, to just alt+F4, and restart the game. Loading inside a running play was and is always much slower, and causes huge memory usage.

Share this comment


Link to comment
Share on other sites

Same problem, and i find the way to solve it. Delete file of user preferences, path: C:\Users\UserName\Documents\Klei\OxygenNotIncluded\kplayerprefs.yaml

Edited by gogn
  • Like 1

Share this comment


Link to comment
Share on other sites
1 hour ago, gogn said:

Same problem, and i find the way to solve it. Delete file of user preferences, path: C:\Users\UserName\Documents\Klei\OxygenNotIncluded\kplayerprefs.yaml

Just tested that on my installation and it works fine. Problem solved , thanks !

It's long ago, but I remember something called transactional files.

Share this comment


Link to comment
Share on other sites

Sadly this happened to me, only the game was just randomly crashing my computer (it seemed)(green screen of death) then it wouldn't load past the logo. I tried this and it works perfectly, and I can play the game again. Not sure about fixing the crashes though.

Share this comment


Link to comment
Share on other sites

Glad you were able to get the game working again! :D 

To anyone else who comes across this issue: If you wouldn't mind posting your log file and your kplayerprefs file here, that would help us figure out what caused this problem in the first place. Thanks!

Where to find your log file

kplayerprefs can be found in the folder above save_files, as described at that link as well.

  • Thanks 1

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now