Game crashes from main menu when clicking "Load Game"


boiledDupe
  • Branch: Live Branch Version: Windows Pending

Here is the stack trace, but I can repro it consistently by clicking on "load game" from the main menu.

 

 

Texture has out of range width / height

  at LoadScreen.SetPreview (System.String filename, System.String basename, UnityEngine.UI.Image preview, System.Boolean fallbackToTimelapse) [0x00000] in <f9baef9e89cf46d89f61eedc4adbd93b>:0 
  at LoadScreen.AddColonyToList (System.Collections.Generic.List`1[T] saves) [0x00000] in <f9baef9e89cf46d89f61eedc4adbd93b>:0 
  at LoadScreen.RefreshColonyList () [0x00000] in <f9baef9e89cf46d89f61eedc4adbd93b>:0 
  at LoadScreen.OnActivate () [0x00000] in <f9baef9e89cf46d89f61eedc4adbd93b>:0 
  at KScreen.Activate () [0x00000] in <6a81623675ea4347b1cfdd3156c4d89d>:0 
  at MainMenu.LoadGame () [0x00000] in <f9baef9e89cf46d89f61eedc4adbd93b>:0 
  at KButton.SignalClick (KKeyCode btn) [0x00000] in <6a81623675ea4347b1cfdd3156c4d89d>:0 
  at KButton.OnPointerClick (UnityEngine.EventSystems.PointerEventData eventData) [0x00000] in <6a81623675ea4347b1cfdd3156c4d89d>:0 
  at UnityEngine.EventSystems.ExecuteEvents.Execute (UnityEngine.EventSystems.IPointerClickHandler handler, UnityEngine.EventSystems.BaseEventData eventData) [0x00000] in <04d0cd30fbf9474897ce2cf447facfe7>:0 
  at UnityEngine.EventSystems.ExecuteEvents.Execute[T] (UnityEngine.GameObject target, UnityEngine.EventSystems.BaseEventData eventData, UnityEngine.EventSystems.ExecuteEvents+EventFunction`1[T1] functor) [0x00000] in <04d0cd30fbf9474897ce2cf447facfe7>:0 
  at UnityEngine.EventSystems.StandaloneInputModule.ReleaseMouse (UnityEngine.EventSystems.PointerEventData pointerEvent, UnityEngine.GameObject currentOverGo) [0x00000] in <04d0cd30fbf9474897ce2cf447facfe7>:0 
  at UnityEngine.EventSystems.StandaloneInputModule.ProcessMousePress (UnityEngine.EventSystems.PointerInputModule+MouseButtonEventData data) [0x00000] in <04d0cd30fbf9474897ce2cf447facfe7>:0 
  at UnityEngine.EventSystems.StandaloneInputModule.ProcessMouseEvent (System.Int32 id) [0x00000] in <04d0cd30fbf9474897ce2cf447facfe7>:0 
  at UnityEngine.EventSystems.StandaloneInputModule.ProcessMouseEvent () [0x00000] in <04d0cd30fbf9474897ce2cf447facfe7>:0 
  at UnityEngine.EventSystems.StandaloneInputModule.Process () [0x00000] in <04d0cd30fbf9474897ce2cf447facfe7>:0 
  at UnityEngine.EventSystems.EventSystem.Update () [0x00000] in <04d0cd30fbf9474897ce2cf447facfe7>:0 
Build: U34-477203-SD


Steps to Reproduce

Open app, click on "load game" from main menu



User Feedback


There's a large image file somewhere in Documents/Klei/OxygenNotIncluded, if you remove it you should be able to play the game.

  • Thanks 2

Share this comment


Link to comment
Share on other sites

I have debug enabled on the machine, and prior to this happening I hit some short cut (maybe backspace) to disable fog of war, and that maybe created a large image?  Since then I have a newer update installed, and can no longer reproduce.  I took a look and was only able to find ~600-700kb png files in the save folders.

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now