Error - Couldn't switch to requested monitor resolution


ras-kar
  • Branch: Live Branch Version: Steam Pending

Every time if I try to start game I get error "Couldn't switch to requested monitor resolution" and game does not start.
Tried different resolution and tried to start as windowed mode, but nothing helps.

ONI_error.png.ce161f57d5ea07683844d851fe5e3a53.png

This started after Automation Upgrade. Played also Automation Preview Update and everything was fine. But after the Automation Upgrade game doesn't start. There was also Windows 10 Fall Creators Update, might be this messed up something?
Also uninstalled game and reinstalled, but still same.


Steps to Reproduce
start game

Status: Pending

This issue has not been confirmed by a developer yet.


  Report Bug


User Feedback


.... .... .... .... ....

Made a clean install to drivers but didn't work, still same thing.
But I can run the game if I disable Nvidea display adapter.

Share this comment


Link to comment
Share on other sites
.... .... ....

Well found someone with the same error on another game and the solution there was to reinstall the drivers. https://us.battle.net/forums/en/hearthstone/topic/20759159663

 

So I think we can try doing things the hard way. Download this and use it to completely wipe the drivers from the system http://www.guru3d.com/files-details/display-driver-uninstaller-download.html

After restarting go download a fresh copy of the drivers and install them and restart again.

Share this comment


Link to comment
Share on other sites
.... ....

Didn't work. Made cleaning with DDU and fresh install to drivers, but still nothing. Also made reinstall to game, but nothing.
I am not sure if it's related but I think GeForce Experience used to see ONI but doesn't anymore.

Share this comment


Link to comment
Share on other sites
.... .... ....

Now I did found out that there are at leats two other games that give me the same error - The Long Dark and Firewatch.

Share this comment


Link to comment
Share on other sites
.... ....

I have tried that, didn't work. Also I usually play on external monitor, and I have tried without it, just on laptop monitor, didn't work also.

Share this comment


Link to comment
Share on other sites
.... ....

Now I did find a solution. Right click on OzygenNotIngluded.exe and then Properties and under Compatibility tab Disable full-screen optimisatsion has to be checked. And then game works like before.

oni-error.thumb.PNG.98dc4654953cb0e2cabd7c22e93bd7a1.PNG

  • Thanks 1

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now