Duplicants try to water algae farms with contaminated water


despairbear
  • Pending

Sometimes my duplicants try to water algae farms with nearby contaminated water. The contaminated water immediately spills off the algae farm into the pit that the dupes got it from, with the result that they appear to get stuck in a loop of continually sucking up and spraying water to no effect. 

I'll try to attach a video of this happening.

bugreport_contamwater.mp4


Steps to Reproduce
The repro seems to be to simply collect contaminated water in a basin within a few tiles of an algae farm.


User Feedback


....

Actually I think what might be happening is that they're trying to suck up the contaminated water, but there is no "contaminated bottled water", so they end up carrying nothing.

Share this comment


Link to comment
Share on other sites
....

I think I saw this happening with regular water as well. The conditions were:

  1. Several algae farms freshly constructed
  2. In a flat area that was slightly flooded with dripwater
  3. Near a basin

The dupes were trying to pick water off the floor and feed it to the algae, but not making progress. The problem cleared up after save/restart/load.

Share this comment


Link to comment
Share on other sites
....


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now