Sign in to follow this  

Duplicants refuse to use Atmo Suit Docks


OneBlackLight
  • Branch: Live Branch Version: Windows Fixed

So I finally got around to playing oni after the merge update hit and now in all my previous games my duplicants just can't or won't interact with the atmo suit docks and sit idle in my base until I disable the checkpoint. 

I've tried changing the settings between vacancy and always allowed and this has no affect on them deciding to stay idle. Because I have multiple atmo suit exit points to the core base I've also blocked the exits down to a single atmo suit checkpoint exit and this also has no effect. The only way I can get them to leave the base now is as stated above by deactivating the atmosuit checkpoint (at which point they all pile out of the base into inferno land and start getting scalded)

Is any one else experiencing this issue or know the root cause?

Footnote: I've tried with mods on and off and there's still no difference in the issue I'm having. (Also if anyone knows how to clear the right hand resource panel please let me know, I can't see the clear all button anymore)

EDIT: I believe I may have resolved this, at least in my instance. I had to close off the boxed in base completely from the rest of the asteroid, manually undock the exo suits, deconstruct and reconstruct the docks and checkpoints, then load up the suits and finally re-open the base to the rest of the asteroid. No longer getting idling issues after this. Hope this report still helps resolve the bug or resolve the issue for anyone else :mrgreen:

20210708133811_1.jpg


Steps to Reproduce

Reload any old save with a boxed in base with single or multiple atmo suit dock exits which are active and set to any combination of vacancy or always.

Sign in to follow this  


User Feedback


A developer has marked this issue as fixed. This means that the issue has been addressed in the current development build and will likely be in the next update.

The atmo suits are not filled with oxygen when loading before merge saves. If undocked and you request them again, they fill with oxygen properly. (At least in my saves.. ). Probably the bug has something to do with atmo suits durability? Base game atmo suits will not break by default but for some reason they also don't have oxygen on load but the game does not recognise that and doesn't start filling them.

I hope it will be fixed before the testing branch goes live for the base game...

 

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now