Sign in to follow this  

Duplicants failing to register they are falling


Zerohayven
  • Branch: Live Branch Version: Windows Fixed

When a tile or transit tube is decontructed while a duplicant is standing on/in it, the duplicant won't register they are falling nor look for a nearby location to stand on (Even if a ladder is literally behind them), I am unsure if it is caused by a animation lock.

This error is quite deadly to duplicants as I caught this bug twice in the past 3 hours (I would have had dead duplicants if I got up at the time and let the game run).

Natural tiles are inclusive to this bug as a robo miner dug out a natural tile made by a shove vole.

The solution to get the duplicant to move again is either restarting the game (doesn't always work) or to build a tile below them or rebuild another transit tube at their location.

(In the picture below, Ada is stuck midair, she is able to continue building/digging as if she is standing on something, but she just can't move)

Screenshot (154).png


Steps to Reproduce

Decontruct tile or transit tube while a duplicant is on/in said tile/tube at the time (it might require a different duplicant or robo miner to decontruct the tile).

(I am unsure if ladders are affected)

I have been unable to recreating this bug on a test map so the conditions might have to be very specific for this bug to activate.

Dupelication of the Duplicant.sav

Sign in to follow this  


User Feedback


A developer has marked this issue as fixed. This means that the issue has been addressed in the current development build and will likely be in the next update.

Changed Status to Known Issue

I've also been unsuccessful in reproducing this bug when I looked at it before. If you find any more insights please let me know. I'll try to look at it again when I have time.

  • Thanks 1

Share this comment


Link to comment
Share on other sites
On 8/20/2021 at 9:43 AM, EricKlei said:

Changed Status to Known Issue

I've also been unsuccessful in reproducing this bug when I looked at it before. If you find any more insights please let me know. I'll try to look at it again when I have time.

So I attempted to recreate the bug but found something slightly different (which may or may not be related but might assist with finding the issue).

By moving the ladder the duplicant is standing on with Alt+Q (dev mode), the duplicant remains stuck with the navigation of the previously positioned ladder as its only navigation (essentially it becomes a phantom ladder),the location is also unbuildable but can have another object (Alt Q) moved back into its location.

While the phantom tile kinda is against my initial concept of being able to build a tile below/on the duplicant to move them again, because the navigation is locked after a decontruct there is essentially no phantom tile ingame (So it might be related)

Recreation conditions (but doesn't always work as shown in the video link enclosed):

*Dev mode (via KLEIPLAY on main menu + CTRL F4)

*Sandbox

*build a ladder in a location where a duplicant can't access to other standable objects.

Have a duplicant stand on the ladder then move the ladder with the Alt Q (from dev mode)

I was recording at the time I was testing this so I edited/uploaded what I thought was important (I will be deleting this video at a later date)

The phantom tile can be seen at 1:22 and it's existence remaining with other tiles around it at 2:35

 

Share this comment


Link to comment
Share on other sites

Moving a building is not without side effects and not something we generally consider when implementing a building. Ladders define an area for ladder movement on creation and clean it up when the building is removed, it does not update when the building is moved. So what you are seeing here is expected.

I believe this bug is different though, since if there was a phantom ladder 1-tile above the ground dupes would still use it without issue. Here's a related issue but with a Triage Cot which exhibits similar behavior.

  • Like 1
  • Thanks 1

Share this comment


Link to comment
Share on other sites
On 8/24/2021 at 9:15 AM, EricKlei said:

Moving a building is not without side effects and not something we generally consider when implementing a building. Ladders define an area for ladder movement on creation and clean it up when the building is removed, it does not update when the building is moved. So what you are seeing here is expected.

I believe this bug is different though, since if there was a phantom ladder 1-tile above the ground dupes would still use it without issue. Here's a related issue but with a Triage Cot which exhibits similar behavior.

Good to know, back to the drawing board I guess for me, If I figure out something else out I'll let you know.

  • Like 1

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now