Duplicant stuck depressurizing oil well (details + video)


ICIPH3R
  • Branch: Live Branch Version: Windows Fixed

Duplicants can get stuck depressurizing an oil well while it is disabled/unpowered, causing the dupe to freeze forever in its current animation frame.

This is a commonly reported bug. One could argue this was intended by design, if only it wasn't for the fact that the dupe animation glitches out and no further tasks will be processed by the dupe. This can cause a lot of grief particularly for new players as it will prevent the dupe from accepting any further tasks and requires either a mod to fix, or motion sensors/automation to force enable the well as a workaround.

If we take a look at the "clean outhouse" task below for example - it has an appropriate check in place that the oil well also needs to have:

image.thumb.png.18a89c934ae4c871d563b6e02fba6976.png

"Clean Outhouse" cannot be performed when the outhouse is disabled ("Not Operational"). Ideally it should be the same approach for depressurizing oil wells (cannot depressurize while oil well is not operational). It appears the bug is that for disabled/non-operational oil wells the depressurize task is still valid and assigned to the dupe, but the actual action of depressurizing cannot be performed by the dupe - shown in video below.

I have compiled a list of all related bug reports which can then all be marked as resolved:


Steps to Reproduce

Bug occurs when well is inactive due to no power:

Bug occurs when well is inactive due to no fluid input:

 

  • Big Ups 3


User Feedback


A developer has marked this issue as fixed. This means that the issue has been addressed in the current development build and will likely be in the next update.

There is a missing stuck cause in your description (that's detailed in one of the ticket you linked): no water present on the oil well liquid pipe input also cause the Dupe to get stuck. That particular one caused me some grief in the past when using superheated 10% water packets.

Share this comment


Link to comment
Share on other sites

Yep have added another example video of this case. Although I believe the underlying bug is the same: an inactive/non-operational oil well sending dupes depressurize tasks that fundamentally cannot be completed until the well is next active.

Share this comment


Link to comment
Share on other sites

+1, seeing this as well, exactly as described by ICIPH3R.

  1. Have oil well controlled by automation network (a hydro sensor in my case, so my oil biome doesn't overflow)
  2. Dup goes to vent well
  3. Well is disabled by automation network before vent is complete
  4. Dup freezes with no animation until automation network is re-enabled

Build U40-494396-S.

 

Share this comment


Link to comment
Share on other sites

Oil well is fixed currently for the testing branch after update 496173 "Fixed issue where Duplicants could get stuck depressurizing an Oil Well"

Now the well needs to be enabled and have water running through it in order for an errand for "release pressure" to start. If either of these conditions isn't happening, the dupe doesn't go to the well at all.

Share this comment


Link to comment
Share on other sites

Saw an update was pushed today with a fix for this bug - woohoo!!! Just tested and can confirm everything working as sakura_sk mentioned. Time to do a mass bug close/resolve :D

  • Like 1

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now