Custom worldgen seeds turn into 0


Xheepey87
  • Branch: Live Branch Version: Steam Pending

29dxq45.jpg1o99n4.jpg

Here's a issue when I use the custom seed. Just look at the pics.

Random seeds are fine. But if you input the large seed, it will be 0.


Steps to Reproduce
Use the seed which is input


User Feedback


.... ....

Seeds are integers 'int' in code. That means max number is 2147483647 = 7FFFFFFF.

Looking at your image it seems like you used 748298374893 which is too big and ends as 0.
I tried that and got world seed zero and in log this:

[ INFO  ] Set world to [worlds/Default] C:/Program Files (x86)/Steam/steamapps/common/OxygenNotIncluded/OxygenNotIncluded_Data/StreamingAssets\worldgen/
[ INFO  ] Using player defined seed
Seeds are [0/0/0/0]

 

But somewhere that large number survived... (at least in output_log.txt)

[ INFO  ] Set world to [worlds/Default] C:/Program Files (x86)/Steam/steamapps/common/OxygenNotIncluded/OxygenNotIncluded_Data/StreamingAssets\worldgen/
Shader warmup: 80 shaders 204 combinations 0.001s
[ INFO  ] Custom Settings: ImmuneSystem=Default,Stress=Default,StressBreaks=Default,WorldgenSeed=748298374893,


So maybe bug is that it is possible to enter seed number out of range?

 

  • Thanks 1

Share this comment


Link to comment
Share on other sites
....
17 hours ago, AlexRou said:

827938 works fine... which OS are you on? And can you upload the game log after trying to use a custom seed that fails?

Thanks for your reply!

In fact I use my phone number as the seed at first, after that I only use large numbers and not try the smaller numbers.

10 hours ago, bzgzd said:

Seeds are integers 'int' in code. That means max number is 2147483647 = 7FFFFFFF.

Looking at your image it seems like you used 748298374893 which is too big and ends as 0.

You're right. The large number is the key. I have changed the description.

Share this comment


Link to comment
Share on other sites
....

I can confirm this as well.

As an Mod Developer, the int32 is limited as mentioned, so as an suggestion either limit it to 8 or 9 digits number.
That way this should not happen :p

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now