Sign in to follow this  

Crashes at start


sunsong99
  • Branch: Live Branch Version: Windows Pending

Hi, I play oxygen not included in steam. I have reinstalled, updated, verified files, but it still gives me an object reference null error and crashes at the start. Please help?
 

NullReferenceException: Object reference not set to an instance of an object

KModalScreen.OnCmpDisable () (at <1c58b1f98f5849baa9083bfd5185b144>:0)
KMonoBehaviour.OnDisable () (at <f30d3c85d1f64155aa0dc6c7adb0d1eb>:0)
UnityEngine.GameObject:SetActive(Boolean)
ConfirmDialogScreen:OnPrefabInit()
KMonoBehaviour:InitializeComponent()
KMonoBehaviour:Awake()
UnityEngine.Object:Instantiate(GameObject, Transform, Boolean)
Util:KInstantiateUI(GameObject, GameObject, Boolean)
Util:KInstantiateUI(GameObject, GameObject, Boolean)
InitializeCheck:ShowErrorDialog(String)
InitializeCheck:ShowFileErrorDialogs()
InitializeCheck:Awake()
UnityEngine.Object:Instantiate(GameObject, Vector3, Quaternion, Transform)
Util:KInstantiate(GameObject, Vector3, Quaternion, GameObject, String, Boolean, Int32)
Util:KInstantiate(GameObject, GameObject, String)
LaunchInitializer:Update()
 


Steps to Reproduce

open game
see klei screen
crash

Sign in to follow this  


User Feedback


.... ....

Likewise; boot it up, see the Klei screen, a small pop-up blips and then it crashes.
I think I gotta picture, I'll see if I can link.
I will say, I was using mods prior to THIS problem.
It kept crashing me everytime it would auto-save, so I decided to turn off my mods in the crash screen as to single out which was responsible for the crashes.
Once I booted back up vanilla it started with this, dunno why it's looking for mods.
IIRC, there was a microsoft or avast security update prior to this I had, could that be part of the problem?

ONI - WTF -Crash_004.png

Share this comment


Link to comment
Share on other sites
....

 Ok, sorry for double-posting but I found out what MY problem was, as it turned out others were having the same issue.
 
https://steamcommunity.com/app/457140/discussions/3/1639793203764371202/ 

So after I read this, I followed the directions.
Turns out, when my Avast updated it flushed out my Exceptions and Blocked/Allowed Apps.
Alright then, reinstated all the pathways and set what I could remember back the way it was.
Booted up ONI, and it didn't crash! So send a big 'thank you!' to F3n1x over on steam if you can.

Dunno if this'll help OP, but if you gotta Anti-virus, make sure ONI and the pathways(Both under Steam in programs and in documents) are allowed access.
Hope this helps, if not, keep strong and fight on.

Happy holidays everybody!

((Daddy's home my dumpty dupes!!!))

Edited by ChainedDjinn
Grammer and wordcount

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now