Crash to Desktop / Dupes build ultra cold and hot structures


Taltral
  • Branch: Live Branch Version: Windows Fixed

Hello,

I encounter a bug, where the game crashes. When my duplicants build new structure, the temperature is being set to -273.2C or 211234100000000000000C. The structures then alternate between both temperatures or stay fixed sometimes(see attached Oxygen Not Included 17.06.2018 14_32_09.mp4)

Save and reload fixes those structure which are at -273.2C, but those who are hot melt down und the game crashes (No "Blackhole has eaten my game" Message).

I attached 2 Savegames:

I am already using the cosmic_upgrade_hotfix- branch (CU-373838), which was mentioned multiple times in other bug report as possible solution. I think there are multiple different bug reports which may have the same cause.

 

SimDLL_CRASH_release_273838_20180617-14.35.46.dmp

SimDLL_CRASH_release_273838_20180617-14.39.02.dmp


Steps to Reproduce
Not sure; load savegame The Beautiful Lab Cycle 198.sav and build some structures, then take a look at the temperature overlay.


User Feedback


A developer has marked this issue as fixed. This means that the issue has been addressed in the current development build and will likely be in the next update.

I am getting the same issue including the alternating temperatures (values slightly different but same idea) and am also on the current hotfix branch.  Started this map in the hotfix branch with no debug/sandbox enabled at any point.

This wire segment was just built moments before.  Many other items are oddly too cold given their history but nothing outside the normal ranges other than this wire.

20180617141851_1.thumb.jpg.95cdd3e2aff82d98a738ca0267fbfc53.jpg20180617142033_1.thumb.jpg.5e9d878474ea891de52005babb875aff.jpg

TemperatureOverflow.sav

output_log.txt

Share this comment


Link to comment
Share on other sites

@Cheerio

The functional save provided a useful log

NullReferenceException: Object reference not set to an instance of an object
  at StructureTemperatureComponents.OnGetTemperature (.PrimaryElement primary_element) [0x00000] in <filename unknown>:0 
  at PrimaryElement.get_Temperature () [0x00000] in <filename unknown>:0 
  at InfraredVisualizerData.Update () [0x00000] in <filename unknown>:0 
  at InfraredVisualizerComponents.UpdateTemperature () [0x00000] in <filename unknown>:0 
  at Infrared.Update () [0x00000] in <filename unknown>:0 

But I think all the saves that saved the bugged temperature are ruined

Edited by SlowMaybe
it can be fixed

Share this comment


Link to comment
Share on other sites

I have seen the -272.2°C structures (and they don't absorb nearby energy until the save is reloaded) but I haven't seen the super-heated ones... until now.  The cold stuff is within a manageable range of temperature – a 100kg ladder or five won't break your base in all likelihood – but the hot stuff is ridiculous.  The highest temp I have seen reported in the bug tracker so far is ~400+ nonillion.

So fast forward a bit: I haven't seen the issue pop up in my save so I keep playing.  One of the issues I have had is gasses supercooling in random lengths of pipe, but the hotfix build has fixed that.  In the (hopefully attached) save, I have this pipe that I have been venting deeper undesirable gasses to space with, and none of the pipes were built at abnormal temperatures.  I looked at them again a bit later, and I saw a few pipes had turned red, and next to them, a few had turned blue....  The hottest pipe is 20.1 decillion °C (if I counted the zeros right).

Screenshot_20180617_182147.thumb.png.ff7606d30094a8a25281b09d6a741153.png

Now they won't explode until I reload the save (and it does explode when I do that, bypassing the black hole and crashing straight to desktop), so I have hope that if I take sandbox delete to them, the save will be recoverable.  I tried this and saved that separately, but haven't tried reloading the 'clean' one yet.

Linux version, cosmic_upgrade_hotfix enabled.

Ohno.sav

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now