Sign in to follow this  

Crash on loading save (Cycle 5490)


LtShep
  • Branch: Live Branch Version: Windows Fixed

When the most recent update dropped my save file won't load without crashing. I have disable all mods and tried checking integrity of the game via Steam, and also tried reinstalling GPU drivers just in case. So far nothing I have tried fixes the crash, it seems to happen around 20-seconds after loading (3x speed).

I haven't been able to narrow down a specific reason, but there are a lot of "[WARNING] ThoughtGraph added twice ThoughtGraph()" in the output_log, and I've never seen that before. Also, "[WARNING] Effective mass cannot be greater than capacity!" shows up a lot but I had noticed that before this update and it hasn't caused problems; correct me if I'm wrong, but I believe that's because of the mass storage + cleanup I have currently tasked. No glitchy liquid or gas compression.

edit: This is a full frozen-until-force-quit crash

 

Overkill Colony (crash).sav


Steps to Reproduce

Load save, un-pause and wait.

Sign in to follow this  


User Feedback


A developer has marked this issue as fixed. This means that the issue has been addressed in the current development build and will likely be in the next update.
.... .... .... ....

There was a bug introduced in the last update that causes an infinite hang if a dupe entered/left the game world while in various states ("Holding Breath" being a common one). Dupes enter/exit the game world when they die, but also when they enter and leave rockets. I don't recall offhand what was the case for your save, but I did verify that it no longer crashes with the fix.

  • Thanks 3

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now