Constant "error occurred" crashes


Galifrey1965
  • Branch: Live Branch Version: Windows Fixed

Unplayable since the patch for any longer than a few cycles depending on which map I am playing. 

Game Files Validated

Mods enabled and disabled

Always seems to crash around the same point give or take  60 seconds

Both of these are the latest saves from 2 of my bases, One crashes at cycle 1400 the other pretty much just after loading on cycle 657

Petroleum boiler stable Cycle 657.sav (1).sav

Morning after Cycle 1391.sav


Steps to Reproduce
Just play, sit back and watch, doesn't matter.

Status: Fixed

This issue has been fixed in either a future version or updated in a previous version.


  Report Bug


User Feedback


A developer has marked this issue as fixed. This means that the issue has been addressed in the current development build and will likely be in the next update.
....

Output log straight after crash with mods

output_log.txt

 

Also attached with mods

 

Sparklestreaker seems to be the issue

 

[12:34:21.409] [1] [WARNING] AdjustLoad() failed
[12:34:21.660] [1] [WARNING] AdjustLoad() failed
[12:34:21.735] [1] [WARNING] AdjustLoad() failed
[12:36:26.542] [1] [ERROR] Ren Exception in: (Minion).SparkleStreaker.root.overjoyed.Exit
System.NullReferenceException: 
  at (wrapper managed-to-native) UnityEngine.GameObject:GetComponentFastPath (System.Type,intptr)
  at UnityEngine.GameObject.GetComponent[KMonoBehaviour] () [0x00000] in <filename unknown>:0 
  at TracesExtesions.DeleteObject (UnityEngine.GameObject go) [0x00000] in <filename unknown>:0 
  at Util.KDestroyGameObject (UnityEngine.GameObject original) [0x00000] in <filename unknown>:0 
  at SparkleStreaker.<InitializeStates>m__1 (.Instance smi) [0x00000] in <filename unknown>:0 
  at StateMachine`4+GenericInstance[StateMachineType,StateMachineInstanceType,MasterType,DefType].ExecuteActions (.State state, System.Collections.Generic.List`1 actions) [0x00000] in <filename unknown>:0 
Exception in: (Minion).SparkleStreaker.root.overjoyed.Exit
System.NullReferenceException: 
  at (wrapper managed-to-native) UnityEngine.GameObject:GetComponentFastPath (System.Type,intptr)
  at UnityEngine.GameObject.GetComponent[KMonoBehaviour] () [0x00000] in <filename unknown>:0 
  at TracesExtesions.DeleteObject (UnityEngine.GameObject go) [0x00000] in <filename unknown>:0 
  at Util.KDestroyGameObject (UnityEngine.GameObject original) [0x00000] in <filename unknown>:0 
  at SparkleStreaker.<InitializeStates>m__1 (.Instance smi) [0x00000] in <filename unknown>:0 
  at StateMachine`4+GenericInstance[StateMachineType,StateMachineInstanceType,MasterType,DefType].ExecuteActions (.State state, System.Collections.Generic.List`1 actions) [0x00000] in <filename unknown>:0 
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug.bindings.h Line: 43)

output_log2.txt

 

Edited by Galifrey1965

Share this comment


Link to comment
Share on other sites
.... ....

Changed Status to Fixed

Should be fixed and up in the next update soon. Thanks for the report/details.

  • Thanks 1

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now