Sign in to follow this  

Can't store plastic in storage compactors


SteelRodent
  • Branch: Live Branch Version: Windows Pending

Set up a system to make plastic and auto-sweep it onto a conveyor from the polymer presses, but when then plastic reaches the receptacle in my storage area neither the auto-sweeper nor the dupes will put the plastic into the storage compactors. They all act like the plastic isn't there at all (in the receptacle). The dupes will also not pick up the plastic  at the presses (which the auto-sweeper cannot pick up because the conveyor is full).

Checked that all the compactors in range of the sweeper are set to accept plastic, and even tried setting them to accept everything. Everything that I'm able to manufacture so  far will go into the compactors, but NOT plastic.

I've let it sit for 3 cycles and nothing has happened yet. The sweeper picks up all the crap the dupes leave on the floor, but will not touch the plastic.

*Tried saving and reloading the game

*Tried restarting the game

*Tried deconstructing both the receptacle  and the sweeper

*Tried enabling manual operation on the receptacle

*Tried setting priority to 9  on the receptacle

Seed is 1422876295

I built the plastic machines in the ice  biome in the bottom left of the map and the conveyor goes all the way up to the spawn  area (so quite far). If it makes any difference, the entire conveyor system is made of Iron.

NOTE: My game does not appear to generate log files (it's not in either of the ONI folders)
 

20181026190057_1.jpg

Grimy Antfarm.sav


Steps to Reproduce
To replicate: Set up normal oil refinery and polymer presses. Set up standard sweeper to loader to conveyor to receptacle to sweeper system. Place storage compactors. Apply power.

Status: Pending

This issue has not been confirmed by a developer yet.


  Report Bug
Sign in to follow this  


User Feedback


.... ....

Tested your savefile. And it is exactly as psusi said. You must set priority on conveyor receptable lower then priority on your compactor :)  (for example set it to 1 and everything will be ok.)

  • Thanks 1

Share this comment


Link to comment
Share on other sites
....

To add, even when everything else is correctly set up, auto-sweepers sometimes stops working to deliver from receptacles to proper places. It'll be repaired with save/load from my experiences. The frequency of sweeper-freezing has been significantly reduced since Space Industry Update, but still happens from time to time.

Edited by GnyoR

Share this comment


Link to comment
Share on other sites
....

Tested it, and you guys are right. Lowering the priority of the receptacle makes it suddenly work. Although that doesn't make a lot of sense since the sweeper should take stuff from the receptacle no matter what - since only the conveyor can deliver to the receptacle (unless I misunderstand how that system works). It was set to 9, though, which I believe is a side effect spamming the priority tool to get them to rush construction. IMO, if the receptacle is high priority, it should just tell the sweeper to take from that first before the floor or other places.

I did leave it running for a while with the system clogged, and after a while the dupes start to collect plastic from the presses. So I admit I was wrong. The problem is not in the storage compactors, but in how the sweeper works. But while messing around with the priorities I suddenly caught the sweeper take plastic from one storage compactor and putting it into another with the same priority. AFAIK it's not supposed to defragment the storage, although that would be a nice feature.

So yeah, probably not exactly a bug, but I don't think it's obvious enough how to get it working like intended (but then, I'm used to making systems like this in Factorio).

Would like to note that on the sweeper I set up for the compost, all parts are set to 5 and work just fine.

Share this comment


Link to comment
Share on other sites
....

(Resurrecting this)

There's still something going on with plastics and priority as of QoL #1. I've gotten them to disappear off my accessible materials

list a few times by shifting the priority of them, their storage bins, and their presses. (Note: I'm not disabling any of them)

Abode Backup #1 Cycle 239.sav

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now