Building/Digging Unreachable While No Duplicant In Water


astranberg
  • Branch: Live Branch Version: Windows Pending

I was building a large water tank to the south, with a long column of ladders. I had dig and build instructions queued in the bottom, several of which were immediately accessible, but not all of the accessible tasks were lit up (white icons): When any duplicant was in the water, it properly showed all accessible tasks. However, if all duplicate were out of the water (they were headed to get supplies), then several of the tasks lost their accessible status.

I believe the issue is pathfinding related. All of the tasks next to the ladder showed as still accessible. The tasks which required the duplicant to jump off the ladder were not.

I can upload screenshots if requested. Not sure I have the save file anymore.

 


Steps to Reproduce
Que build tasks under water; some accessible by ladder and some by ladder —> ground.

Status: Pending

This issue has not been confirmed by a developer yet.


  Report Bug


User Feedback


....

Dupes have a limited number of water tiles that they calculate in pathfinding. I cant remember how many tiles it it, but it has been like that in the game as long as I can remember

  • Like 1

Share this comment


Link to comment
Share on other sites
....
12 hours ago, Jackblac said:

Dupes have a limited number of water tiles that they calculate in pathfinding. I cant remember how many tiles it it, but it has been like that in the game as long as I can remember

2 squares. Everything further will be ignored. build ladders.

Share this comment


Link to comment
Share on other sites
....

I see this issue regularly. Water does not need to be particularly hot so the bug does not seem to be environmentally motivated.
In the included image, the water is 53 degrees and the conductive wire visible to the left of the unreachable build goes right up to the unreachable build (hidden by the insulated tiles) can be reached and were built as part of the same panning.

It seems that pathing stops after a particular distance.

UPDATE: This seems to have been fixed for me in QOL3.
 

o2ni_01.png

Edited by Damian Alien
Update from QOL3

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now