Build orders ignored despite any priority


Draxbear
  • Branch: Live Branch Version: Linux Pending

I've lots of build orders that are now no longer being actioned for some reason. I've tried a full reload but sadly no luck with that. Just prior to this happening I was making some adjustments to my priorities so its likely that's where things started to go wrong.

The other, most recent change was allocating new skills to create a doctor. Unlikely to be related but it's about the only other recent stand-out change in typical behaviour.

Find attached a screenshot of an Idle builder with all priorities except build turned off and build set at max.

I'm running Ubuntu 18.04.2 LTS and have included an lshw.out file for you to check out for details.

 

20190419_BuildFail00png

lshw.out.gz


Steps to Reproduce
No build orders are being actioned regardless of priority settings.

Status: Pending

This issue has not been confirmed by a developer yet.


  Report Bug


User Feedback


....

Try changing your duplicants priorities to make build more important? Sometimes my dupes refuse to build because of the priorities for me.

 

Share this comment


Link to comment
Share on other sites
....

Thanks for the help, tried that definitely! Aka "Find attached a screenshot of an Idle builder with all priorities except build turned off and build set at max."

I've tried rolling back to earlier saves too and have pending build orders at cycle 1437 and once they're done at 1438 they all switch to supply/other priorities and ignore existing build orders regardless of 1~9 priority with no luck. On the not-quite-plus side I can set build orders to !! Top Priority (Yellow alert) and they get acted upon.

Share this comment


Link to comment
Share on other sites
....

Did you select the Dupe and tell them to move there? There path to get there could be blocked.

Share this comment


Link to comment
Share on other sites
....

Definitely not a pathing issue thanks. See the latest update where setting priority to Top/Yellow alert is a workaround. I have several build orders scattered around the map (which I hope isn't unusual behaviour!) and none of them are seeing any action.

This is not a big priority or show stopper btw. I've started fresh with a new QOL3 build instead. I've kept the related saves around this and am very happy to work towards a fix in case this is some kind of late game (cycle 1438) bug.

Edited by Draxbear
Bit more detail

Share this comment


Link to comment
Share on other sites
....


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now