Auto-sweeper not delivering, content stuck in it


fan_ferrari
  • Branch: Live Branch Version: Windows Fixed

Hello!

 

First of all, it is the first time that I post so I'd like to thank the DEVs for this great game :)

Unfortunately, I encountered a bug with an auto-sweeper that is supposed to pick up igneous rock and deliver it to a conveyor loader.

The problem is that it works for a while then it totally stops working. I tried to reload / relaunch the game but it doesn't work. It does seem to work when I deconstruct then rebuild it.

I also disabled my mods but it doesn't affect its behavior.

The sweeper is connected to automation but the signal is long enough to allow it to sweep (at least 5s, also tried with 30s).

The conveyor works fine and is not blocked.

I don't understand where this is coming from.457140_screenshots_20200517235454_1.thumb.jpg.00501e78b481e6e2a83393737ed7905c.jpg

Cheers!


Steps to Reproduce

N/A



User Feedback


A developer has marked this issue as fixed. This means that the issue has been addressed in the current development build and will likely be in the next update.
.... ....

Bug's still here. Sweeper is storing, and it just never delivers it again. Annoying one.

image.thumb.png.055e87dfe287b475eeaec8be204654cc.png.

image.png.6b57b9b2a49683f98574d7b154859e49.png

Edited by OxCD

Share this comment


Link to comment
Share on other sites
.... ....
On 6/9/2020 at 9:10 PM, Ipsquiggle said:

Ah interesting. We'll take a look. If you have a save file where this reliably happens, we'd appreciate if you could upload it! Thanks.

Hi !

I've posted my save here

It's been some weeks already, but as far as I recall space was fully setup already. So since I noticed it in my space sweepers lastly, I believe it's already happening in the save above. More details and first report I know about this bug is here :

Thanks !

Share this comment


Link to comment
Share on other sites
....

Changed Status to Fixed

Fixed for the next update on the testing branch. Note that on loading the save with this fix, sweepers will drop all the contents in their storage.

  • Like 2
  • Thanks 1

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now