Astronaut disappears after disembarking


frikkenator
  • Branch: Preview Branch Version: Windows Pending

After yesterday's update my astronaut disappears after disembarking the rocket and doesn't show up in my dupes list anymore. It still shows AN astronaut assigned to the rocket, but no name or image is displayed.

frik qol.sav

EDIT: Okay I've done some testing and I think there is a race condition that's causing this, if I run it at normal 1x speed then the bug doesn't happen, but at 3x speed it does. Tested this multiple times and that seems to be the deciding factor.


Steps to Reproduce
In the attached save, just deactivate the circuit with the clock on the left after the rocket has landed. The circuit will extend the gantries causing the astronaut to flash quickly in front of the command module and then disappearing.

Status: Pending

This issue has not been confirmed by a developer yet.


  Report Bug


User Feedback


....

Added an edit: Okay I've done some testing and I think there is a race condition that's causing this, if I run it at normal 1x speed then the bug doesn't happen, but at 3x speed it does. Tested this multiple times and that seems to be the deciding factor.

Share this comment


Link to comment
Share on other sites
....

Yep, It's almost always disappear. I just deconstruct cabin, then astronaut fall down and add to colony again like he/she/it never leave. Then rebuild cabin and assign again. I think I saw this bug on forum before and devs know about it.

The whole rocket update still too raw, a lot of stability change are going to be add in coming patch.

Edited by Outrate

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now