30FPS cap on MX150 (Thinkpad T580)


Baterka
  • Branch: Live Branch Version: Windows Pending

I am using Nvidia MX150 GPU in my laptop ThinkPad T580 with i7-8650U.

When I start game I have 60FPS in menu. Then I make new world and first 10 seconds I have normal 60 FPS. Then they drop and fix on 30FPS permanently.

When I ALT+TAB from game and back into game FPS are again 60FPS for few seconds and then cap on 30FPS.

I checked Nvidia setting but found nothing what can limit it. I think this GPU (even integrated UHD620) is suitable for running this game (at least in first few hours of gameplay) on 60FPS or something around it.

It is deffinitelly capped by game or some setting.


Steps to Reproduce
Use laptop with Nvidia MX150


User Feedback


I dont think its about the GPU. The game does not need a powerful GPU to run smoothly. But its a very CPU-Hungry game. Your CPU has only a power limit of max 25 Watts. I dont know whats the power limit of your thinkpad. It can be from 10W to 25W. 

To clarify: Your CPU runs with 1.9Ghz. It can boost up to 4.2Ghz, but only if the power limit is not reached yet, and even then, only for a few seconds. Then it slows down to 1.9GHz again. And then kicks the cooling solution in. If your device has not sufficient cooling, the CPU will stay in the low 1,9GHz area for a long time, until the system is cooled down again. 

I´ve looked up a test of your modell, and the ystem has a power limit of normal 25W. It allows to speed up to 44W, but only for 28 seconds max. 

And there is a second limit, when the CPU reaches 80°C. 

I think, its not the game causing your problems, but the system powering down your CPU, causing massive performance loss. 

Edited by SharraShimada
  • Like 2

Share this comment


Link to comment
Share on other sites

I understand how the CPU boosting works but fps are capped to 30FPS very fast. I think its not problem of 8 core Q3 2017 CPU.

I will test it more but I think game somehow artifactially capping framerates based on specs and its not accurate.

Share this comment


Link to comment
Share on other sites

Are you using vsync? If so, the way it works is if you drop AT ALL below 60Hz, it steps down to the next level (every other frame), which is 30FPS.

Edit: Appears that is only if they or you don't support triple buffering. Check your vsync/triple buffer settings.

Edited by tommytom2k2

Share this comment


Link to comment
Share on other sites

@tommytom2k2 And I just popped in here planning to mention that exact thing!

Seconding tommy, yeah, this is probably related to vsync. If the frame can't be rendered in less than or equal to 1/60th of a second(Depends on refresh rate actually, but 60 MHz is pretty common), then the frame has to wait until the next pass, so you only get half the refresh rate in frames. Also, as @SharraShimada mentioned, this game is very CPU intensive. Your GPU won't matter in the end. It may be worth getting used to it playing at 30 fps rather than 60 fps. In the long run(late game when there's a huge workload), 60 fps isn't maintainable(except perhaps on high-end systems with a solid single core boosting CPU). I play on a crappy HP laptop from 2010, with an abysmal integrated GPU, and it seems the late game lag is less of an issue for me... Why? Because the game always runs bad for me, so I'm just plain used to it, and it's less of a break from my expectations and muscle memory.

TL;DR: The game's gonna run slow later on, unless you have a modern home version of the Gibson. Might as well get used to it.

Edit: An afterthought I had. Your CPU is likely good enough to keep you at 30+ fps for a good long while. So, keeping that limit in place would probably give you a nice consistent feel to the play.

Edited by Dyrewulfe
Edit is marked as an edit.

Share this comment


Link to comment
Share on other sites

I tested game on I5 3550p what is almost 100% equivalent (by CPU userbench) as my notebook CPU. I had 60FPS whole time even with 7 duplicates.

Let's say ok... My CPU is slow for 60fps. But you also say that vsyc jumps to 30 because cannot maintain 60. How to disable vsync? Because What I really have on 30FPS now is that it have HUGe input lag. I can play 30FPS but not with that input lag. I cant even play games with 60FPS vsync because of input lag

Share this comment


Link to comment
Share on other sites

Next proof of something is wrong with game :)

CPU and GPU goes UP when minimalized (Its 100% running 60FPS). When I pop into game, I have 60FPS few seconds then it drops to 30FPS and also GPu and CPU usage drops...

This must be made by game, because CPU and GPU have good temps and same speeds, so there is 100% no throttling

5d06b927bddad_Poznmka2019-06-16234236.png.b43a4af121c370bce1ac1f6d26c9517c.png5d06b927144fc_Poznmka2019-06-16234226.thumb.png.81b67315eb2fd8ee83c7927125dc766a.png

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now