17.2 tons of 853°C polluted water trapped inside Metal Refinery


deadeuzesse
  • Branch: Live Branch Version: Windows Pending

Hi,

As instructed by Kabrute here, I report this a bug. Not sure if exploit or not.

As you may see in attached screenshot, the refinery is filled with 17.2tons of 853°C of polluted water.

It happened after I set a loop of polluted water from outside the Refinery, dropping in a tank, then reinjected without cooling into the refinery.

As the Refinery is made of abyssalite, I did not noticed it was having a such a hot content.

I realized it when i tried to relocate it and destroyed it. Steam realeased smelt everything in the vicinity.

The ouput pipe that is no more in the attached save file was a regular pipe of abyssalite, that broke when the output polluted water was hot enough to turn into steam.

I think that's when the polluted water started to grow and heat inside, since I'm pretty sure it keeped on working until I destroyed it, even though the output pipe was broken.

attached save file : Spacejunk.sav

 

The refinery can be found south east of printing pod.

 

Thanks for your support and this game ! It is so cool ! -unlike my refinery -_-'

 

853_degrees_17.2tons_pw.png


Steps to Reproduce
Built a refinery and reinject hot polluted water into into untill output turns to steam and breaks pipe. Then, it should be possible to keep on producing with the refinery, but the hot polluted water will not be ouput and starts to heat and build inside the rerfinery.
  • Haha 1


User Feedback


I consider this a bug. Why? Because its a machine, with just so much space inside. If the used coolant is not flushed, no new coolant should be able to enter. Problem solved. 

Share this comment


Link to comment
Share on other sites

I have the same bug with normal water which isn't looped.

I think the expected behaviour is that the inserted Liquid is heated for 60°C and then outputted, right?

 

So even if I pipe in 100°C it should have 160°C at highest.

Right now I have 5t of 541,6°C hot water inside my refinery.

 

oni_ref_bug.png

16a Cycle 1113.sav

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now