Shark Tooth Crown not working

Faintly Macabre
  • Version: PC/MAC/Linux Fixed

Just what it says on the tin. Regardless of whether you put it on before or after boarding a boat, its sanity buff isn't applied.

Steps to Reproduce
Make one, get on a boat, put it on.

User Feedback

A developer has marked this issue as fixed. This means that the issue has been addressed in the current development build and will likely be in the next update.
.... .... ....

Hi - I also encountered the issue in my game (SW world generated before the HSH update). It's an RoG game where I built the seaworthy and travelled to SW. As for symptoms - no up-arrow appears and sanity remains static (below 100%)

I'm not entirely certain but I think I also tried the straightforward case - generate new SW world -> give myself the crown -> GiveAllRecipes -> build and place boat -> set sanity to 60% ->  board boat -> equip crown. No change, sanity still remained static. (It may have been Walani + her surfboard, does that change things? In the main game I have Wickerbottom and used row- and armoured boats.)

Share this comment

Link to comment
Share on other sites

I did find situations where it would fail to work. The problem seemed to be when you were on the boat and put the crown on or off. Sometimes it would work and sometimes it didn't. Looking at the code, I'm not sure why it worked sometimes at all in that situation. I've made it so that it will check whether it needs to turn on during equipping and unequipping and that seems to have solved it. 

Share this comment

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now