Sails disappear when moving from boat tonboat


crazy_curlew
  • Version: PC/MAC/Linux Fixed

This happened to me twice - found a boat in the ocean  (rowboats) both with existing sails and lights. When moving to the new boat and trying to unequip the sail and light from old boat, both sails disappear. 


Steps to Reproduce
Try to unequip the sail of one boat while on another also with a sail

Status: Fixed

This issue has been fixed in either a future version or updated in a previous version.


  Report Bug


User Feedback


A developer has marked this issue as fixed. This means that the issue has been addressed in the current development build and will likely be in the next update.
....

In your repro steps, it seems you are on one boat, and try to un-equip the sail on a different boat. Is that what you intended to say? I'm not sure how to un-equip a sail on a boat I am not standing on. 

But I was able to jump over to a found rowboat and unequip the sail, take it over to my old boat and equip it fine.

Share this comment


Link to comment
Share on other sites
.... ....
23 minutes ago, Jason said:

In your repro steps, it seems you are on one boat, and try to un-equip the sail on a different boat. Is that what you intended to say? I'm not sure how to un-equip a sail on a boat I am not standing on. 

But I was able to jump over to a found rowboat and unequip the sail, take it over to my old boat and equip it fine.

Hey Jason, I think, I've found the problem. You can inspect other boats' inventories via left-click while standing on another boat.

5a1751b30d87b_Inspectingboat.png.225774aeab11a8a0a03a96f458b8d832.png

If you right-click on the sail of the other boat, it works just fine and you're holding the sail with your cursor. But if you left-click (which says "unequipp"), the sail from the boat you're standing on correctly lands in your inventory, while the sail from the other boat completely disappears.

This can also be reproduced by having a Boat Torch, Lantern or Cannon attached and by unequipping a Boat Cannon from another boat via left-click.

Share this comment


Link to comment
Share on other sites
....

Aha. I had a hammer in my hand so I couldn't "inspect" the other boat ;)  I see the issue now fine. Thanks for the help Mueck!

  • Thanks 1

Share this comment


Link to comment
Share on other sites
....


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now