Flotsam no longer spawns.

  • Version: PC/MAC/Linux Pending

Flotsam seemingly only spawns once after the player has discovered the Sunken Boat, and then despawns forever. This makes destroying the Sunken Bot the only option if players want the trinket to create the Seaworther.

Steps to Reproduce
Make a save file, make it RoG and SW compatible. Find the Sunken Boat and then come back to it a few days later. Flotsam ceases to spawn from that point on, though I may be wrong.

Status: Pending

This issue has not been confirmed by a developer yet.

  Report Bug

User Feedback

.... ....
On 11/15/2016 at 6:28 PM, C0Rb3N said:

Hi. What version of the game are you playing?

Latest version. Rev. 193934 WIN32_STEAM. I only use Geometric Placement.

Share this comment

Link to comment
Share on other sites

Interesting... I'd been noticing a complete lack of flotsam in a few of my games, even before discovering the Sunken Boat, but just figured I was unlucky - maybe this explains it!

Share this comment

Link to comment
Share on other sites

The thing is, this issue has been around since... well, I'll go on a limb and say, since the official release of SW. Maybe even since beta launch, I'm not sure. Before, when SW was only announced, I remember playing RoG sometime in the summer of 2015, and flotsam back then would spawn near water on a daily basis. After that, SW beta was released, so naturally I didn't play RoG for a long time. Only by spring of 2016 I tried RoG again and, to my disappointment, I found several bugs that ruined the experience for me.

One of them was that floatsam never spawned after the initial batch found near the parrot. So it didn't make much sense creating a SW-compatible RoG world, since you wouldn't be able to assemble a Seaworthy in RoG (apart from breaking the sunken boat).

Another one - was that when a chest started smoldering during summer, pressing on it only allowed you to open it, not extinguish, and pressing SPACE next to it did nothing. Only leaving the game and reentering made the smoldering stop and let me save my base while I didn't have other means of firefighting. It got annoying pretty quickly, so I just dropped that world.

I tried to make a non-SW-compatible world, and I noticed that when I cook a meal in a crockpot, it doesn't show when it's done, the pot seems empty.


I made entries about the first two bugs on the bugtracker here some half a year ago, but since then they were archived or whatever, but they are no longer on display. Perhaps, I was wrong to categorize them under RoG bugtracker, but that doesn't deny the fact, that these issues need addressing. I'm surprised they are still there in the latest version of the game.

Share this comment

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now