[Crash] Game crashing after the new update while using the pitchfork.


MonsieurO
  • Version: PC/MAC/Linux Fixed

Category

Crash

Platform

Steam


Do you use mods?
 
yes (geometric placement, display food value)
 

Version Number

10-46-04, rev 193-193

Issue title

Game crashes after recent update while digging up some turf

Steps to reproduce

- Get the update

- Load a previously saved game (a RoG save, compatible with a shipwrecked world)

- Take a pitchfork

- Try to dig up some turf

Describe your issue 

After the recent update, I tried to dig up some turf, and the game crashed. I disabled one of my two mods, and something weird happened : I could dig up the turfs, but they would just disappear (and couldnt be picked up, obv), so I disabled the other mod, and the error message came back.

Capture d’écran (3).png


Steps to Reproduce
- Get the update - Load a previously saved game (a RoG save, compatible with a shipwrecked world) - Take a pitchfork - Try to dig up some turf

Status: Fixed

This issue has been fixed in either a future version or updated in a previous version.


  Report Bug


User Feedback


A developer has marked this issue as fixed. This means that the issue has been addressed in the current development build and will likely be in the next update.
.... .... ....

Figured no sense in making a new thread.

Playing on PC Steam version, still getting this bug after hotfix. No mods installed. First verified game integrity then just now completely reinstalled game to make sure I got the newest update. 

Using the pitchfork at all in a ROG world, (not linked to a shipwrecked world but compatibility set to yes.) makes the game crash to this screen I've included. 

Screenshot (3).png

 

Edit: Just adding that I created a fresh world post-hotfix and got an identical crash and the exact same error message using the pitchfork on many different types of turf...

Edited by GREGDREW
Addition to bug complaint

Share this comment


Link to comment
Share on other sites
.... ....

Yep, didn't get any hotfix, maybe there's a special way to retrieve it ? I'm still at rev193-193, and so are the others (looking at their pictures).

Edited by MonsieurO

Share this comment


Link to comment
Share on other sites
....
3 hours ago, MonsieurO said:

Yep, didn't get any hotfix, maybe there's a special way to retrieve it ? I'm still at rev193-193, and so are the others (looking at their pictures).

Same here, the game is still at 193193.

bug.png

Share this comment


Link to comment
Share on other sites
....
21 hours ago, Faultz said:

Can confirm, getting the same error still not fixed.

Didn't see any reply yet.

Going through the error message, it seems to me that two errors occur at \DLC0002\scripts\components\terraformer.lua.

If you guys really wanna play this game before the Rev.194 hotfix is TRUELY released, i have 2 possible solutions for you guys

******************************

Op1. Run a ROG ONLY game, not compatible with SW, The ROG-only world does not recall terraformer.lua in the DLC002 folder, so your game should not produce a crash.

******************************

Op2. use my DIY modified lua file (personal use only)

I added a 'if statement' for the flooding related line so it only works in SW world, which means it stop to try indexing field 'flooding' in other worlds (volcano, ROG...)

simple change 

                if GetWorld().components.flooding.mode == "tides" then
                    setTileBlocking(false, pt)
                end

into

            if basetile == GROUND.BEACH then
                if GetWorld().components.flooding.mode == "tides" then
                    setTileBlocking(false, pt)
                end
            end

another conditional statement line has been added for the latter lines also.

Download this file, and replace the bugged one in your Don't starve folder. Mine is at C:\Program Files (x86)\Steam\steamapps\common\dont_starve\data\DLC0002\scripts\components

I did a basic test in one SW world and one ROG-SW world, both worlds worked.

******************************

At last, please stick to OFFICIAL hotfix after it is released.

terraformer.lua

Edited by Amberboss

Share this comment


Link to comment
Share on other sites
....

This is also happening to me after the last update and I'm still on 193-193. I disabled mods and was able to dig it but no turf popped up. Either way this is the second issue that crashed my game since the update. I'm guessing you guys are making a lot of changes under the hood which is great to see but it's causing more problems than it solved.

Screen Shot 2016-10-15 at 11.46.20 PM.png

Still no hot fix :/

Edited by Maestromatic

Share this comment


Link to comment
Share on other sites
....

Receiving same error messages, Mods completely turned off. I tested the pitchfork in RoG and vanilla Don't starve. However the pitchfork works in Shipwrecked for me.

Share this comment


Link to comment
Share on other sites
.... ....


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now