[Beta] Game crashes when loading savegame after traveling through the Seaworthy


MonsieurO
  • Version: PC/MAC/Linux Pending

Dear game developpers,

I recently joined the beta branch, and kept playing my 2k days game. I jumped from RoG to SW and ended up switching world in SW. I explored the new world, found the seaworthy and eventually used it to go back to my former RoG base. While doing so, the client crashed on the "Loading screen", without any message whatsoever. It just stayed on this screen until the client eventually dissapeared on its own.

When I launched back the game, I got a message that the client didn't start correctly last time and that my few mods (Recipe merger, geometric placement, combined status and quick drop) might be the reason for that. I then tried to load my saved game (which appeared as "survival 1 2210", which would mean the world jumping actually happened) but the game crashed again the same way.

I tried to disable / enable the mods while switching from the beta version to the regular version, but the game keeps crashing whenever I try to load this savegame. I have no issues loading other savegames.

Thanks in advance.

PS : I put my log file in attachment, if my saves are needed I can give them too

log.txt


Steps to Reproduce
Have a connected RoG and SW world - Install the Beta - Go to SW - Jump world - Find the seaworthy - Use it.


User Feedback


I "fixed" the problem by loading my savegame on Ubuntu, then loading it again on windows, which worked for some unexplained reason. I can play on this save again, but have no idea what cause the bug nor if it might happen again.

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now