Sign in to follow this  

Skyworthy doesn't take me back to Hamlet


DigitzSnek
  • Version: PC/MAC/Linux Pending

So I got a hamlet save file with a linked RoG. When I tried to go back to Hamlet the second time, I jumped in the Skyworthy (there is an item on the ground nearby) and it does the animation. My game loads but, instead of teleporting me, it spawns me in a copy of my RoG? Because the item on the ground wasn't there. When I re-use the Skyworthy and choose "Survival", I go back to my original RoG with the item on the ground.

So the game recognizes the copy of my RoG as my Hamlet world and I'm afraid I lost Hamlet forever on that save :(
 

I already tried disabling my mods, reloading the game and rebuilding the SkyWorthy...


Steps to Reproduce

I just gathered a bunch of RoG items to take back with me to Hamlet. I already succesfully traveled back once before this bug. So this problem is really sudden.

Edit: I did die in RoG and got touch stone revived if this matters

  • Sad 1
Sign in to follow this  


User Feedback


There are no comments to display.



Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now