Sign in to follow this  

Cannot load my save - Out of memory error


MrNaxeros
  • Version: PC/MAC/Linux Fixed

My 700 day save can no longer be accessed. I have traveled in RoG to the next world with Teleportato and constructed  about half of my new mega base. I traveled to the Hamlet world at day ~80. To my surprise the Hamlet world was not reset. The game was lagging hard, but after ending Aporkalypse I decided to go to the Shipwrecked world to check if that world wasn't resetted either... And here is where the game refused to load it, giving me Out of Memory error.

I have turned off all my mods, enabled all performance options, and it still just can't handle my old SW world.

I would like to point out that I had the same problem before, but just enabling performance options fixed the it, and I don't remember adding anything to my SW base that would overload the game.

I have made a bug report in-game.


Steps to Reproduce
Have big bases in every world and attempt to travel between all of them.

Status: Fixed

This issue has been fixed in either a future version or updated in a previous version.


  Report Bug
Sign in to follow this  


User Feedback


A developer has marked this issue as fixed. This means that the issue has been addressed in the current development build and will likely be in the next update.
....

Have you tried enabling Dynamic Asset Loading in the Options (Second page of options)?

If that helps (I hope so!) and you had small textures enabled you could disable that as it shouldn't be needed then.

If that doesn't help I'll have to look at your savegame because then something fishy is going on.

  • Thanks 1

Share this comment


Link to comment
Share on other sites
....

I tried all four combinations of netbook mode and small textures with dynamic asset loading set to all. It didn't work.

Share this comment


Link to comment
Share on other sites
....

Hmmm, that's odd.

Did you quit and restart the game for the dynamic asset loading to take effect?

I'll look at your submitted save, but could I ask you to make it crash with dynamic asset loading enabled and then submit a bug report with your forum username as the comment? 

Edit: Nevermind, can confirm something fishy is going on. Investigating.

  • Thanks 2

Share this comment


Link to comment
Share on other sites
....

This should be fixed in the next update. I was able to load it without dynamic asset loading even but the world does take a lot of memory, I'd advise having it on if it works well on your system.

  • Thanks 1

Share this comment


Link to comment
Share on other sites
.... ....


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now