Can we please get a fix for the ballphins?


QuartzBeam
  • Version: PC/MAC/Linux Pending

Figured I'd report this again, since the first 3 or so reports got no response and, most importantly, no fix.

Ballphins spawned from Ballphin Palaces behave weirdly due to their herd mechanics. Normally, they attach themselves to a nearby ballphin pod or create a new one if they can't find one. However, sooner or later, something will but out and one day they'll decide to spawn and attach themselves to a new ballphin pod miles away from their Palace. I'm guessing something causes them to not detect their existing ballphin pod.

Depending on whether they are in open ocean (most of SW) or in an enclosed space (either Hamlet pods or a sea wall-surrounded area in SW), things progress differently.

In open ocean, they will swim away from their home to find this new ballphin pod they've spawned. Eventually, they will move too far away and become unloaded. This results in them being stuck away from their homes, as their homeseeker component will not activate at dusk and they won't come back unless the player goes out to find them and escort them home.

In enclosed spaces, they will become stuck swimming against the shore or sea walls all day long. However, when dusk comes, they will return to their homes, only to repeat the whole thing again come morning. Slot 1 of the attached save file belongs in this category.

Using c_countprefabs, it appears that there are 25 ballphin pods in total, but only 15 ballphin palaces. The ballphins stuck swimming against the shore (or, in one case, stuck swimming against a lily pad) are also 15, so I'm fairly certain the behavior only affects ballphins spawned from palaces. And when I used c_gonext("ballphinpod") I ended up in the void, as shown in the screenshot.

remote.7z

20190615175023_1.jpg


Steps to Reproduce
1. Build a few ballphin palaces. 2. Wait a few days. After a while, the ballphins that come out of the palace each morning will spawn extra ballphin pods far far away. This can be seen with c_countprefabs and c_findnext.

Status: Pending

This issue has not been confirmed by a developer yet.


  • Like 2
  Report Bug


User Feedback


....

Kinda surprised a few Bugs like this dont even get a Response at least

Share this comment


Link to comment
Share on other sites
....
8 hours ago, Revior said:

Kinda surprised a few Bugs like this dont even get a Response at least

Important to remember its the weekend so I'm pretty sure the developers are out of office during this time. They usually start being much more active again from what I've observed around Tuesday. 

Share this comment


Link to comment
Share on other sites
....
15 hours ago, Portmanteau said:

Important to remember its the weekend so I'm pretty sure the developers are out of office during this time. They usually start being much more active again from what I've observed around Tuesday. 

I think Revior meant the lack of response in previous reportings of the bug.

Share this comment


Link to comment
Share on other sites
....
6 hours ago, QuartzBeam said:

I think Revior meant the lack of response in previous reportings of the bug.

Right you are indeed

 

Share this comment


Link to comment
Share on other sites
....

I wasn't able to track down exactly why this happens. But in looking for the problem, I found a different problem with the way Ballphin Palaces and Ballphin Herds worked together. It may be that the changes made there might clear this up?

  • Thanks 4

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now