world regen bug


pandaman1992
  • Version: PC/MAC/Linux Pending

game regenerates the world every time i load into a hamlet world. i save, quit, and immediately load back in and it makes a fresh world every time. however, it DOES save the custom world settings. i have looked and cant find anyone else who has had this issue. im only using the hamlet option. no RoG or SW options.


Steps to Reproduce
make world, play or do nothing, save and quit, load back into world.

Status: Pending

This issue has not been confirmed by a developer yet.


  Report Bug


User Feedback


....

Hi,

Thanks for the report, that's definitely odd.

Are you using any mods?

Could you upload your log.txt and backup_log.txt?

Thanks!

 

 

Share this comment


Link to comment
Share on other sites
....
19 hours ago, bizziboi said:

Hi,

Thanks for the report, that's definitely odd.

Are you using any mods?

Could you upload your log.txt and backup_log.txt?

Thanks!

 

 

yes I'm using a few mods. but nothing that alters terrain or anything.

here's the logs you requested

backup_log.txt

log.txt

however, I've only used the two new characters on making my worlds so far. not sure if that would mean any difference though.

Share this comment


Link to comment
Share on other sites
....

Hi, that helped.

I think you use a mod to have more save slots, and the game is running short on cloud storage space. If you can afford it, deleting 1 or 2 saveslots should fix this. We are investigating a solution.

Share this comment


Link to comment
Share on other sites
....

You might be able to workaround this by disabling Steam's cloud feature.  Doing so won't let you sync your saves to the Steam servers for multiple computer use and emergency backups, but it should let you keep the world locally.

  • Thanks 1

Share this comment


Link to comment
Share on other sites
....
22 hours ago, bizziboi said:

Hi, that helped.

I think you use a mod to have more save slots, and the game is running short on cloud storage space. If you can afford it, deleting 1 or 2 saveslots should fix this. We are investigating a solution.

i thought that it was the more saves as well. so i turned it off. but when i tested it, the bug persists.

 

16 hours ago, CarlZalph said:

You might be able to workaround this by disabling Steam's cloud feature.  Doing so won't let you sync your saves to the Steam servers for multiple computer use and emergency backups, but it should let you keep the world locally.

i'll try this workaround shortly and update if it works or not.

 

UPDATE: tried turning off the steam cloud function. but the bug is still persisting. I've also tried in this recent test: using a non hamlet character (wolfgang to be exact), making the world medium instead of large, and turning off the extra save slots again.

Edited by pandaman1992

Share this comment


Link to comment
Share on other sites
.... .... .... ....

@pandaman1992

Thanks, how did you disable the cloud? Because the game detects it as still being enabled - from the log:

Quote

Cloud enabled: true
    Enabled app: false    Enabled account: true
    Num files: 200
    Quota used: 47.990 Mbytes / 100.000 Mbytes

Did you disable it by rightclicking Don't Starve in your library and deselecting it under updates? If so, maybe try restarting steam because it's odd the game detects it wrong.

image.png

 

  • Thanks 1

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now