Sign in to follow this  

Don't Starve will not lauch


Usagibro
  • Version: PC/MAC/Linux Pending

I don't know if this is the correct place to post this issue because it may just be an issue on my end, but ever since the update don't starve hasn't been launching on steam. When I try to launch it a blank window will pop up and then instantly disappear. I've tried verifying the cache, reinstalling, and running as administrator and so far none of them have worked. I don't recall doing anything that would have caused this before the update and I've been stumped on how to fix it. If this is a bug and not a problem on my end then I hope this helps. Thanks!

Here is the log in case that helps:

[00:00:01]: 
System Memory:
    Memory Load: 43%
    Available Physical Memory: 4553m/8130m
    Available Page File: 11915m/16322m
    Available Virtual Memory: 3918m/4095m
    Available Extended Virtual Memory: 0m
[00:00:01]: 
Process Memory:
    Peak Working Set Size: 35m
    Working Set Size: 35m
    Quota Peak Page Pool Usage: 302k
    Quota Page Pool Usage: 280k
    Quota Peak Non Paged Pool Usage:24k
    Quota Non Paged Pool Usage: 23k
    Page File Usage: 11m
    Peak Page File Usage: 11m
[00:00:01]: Starting up
[00:00:01]: Don't Starve: 303992 WIN32_STEAM
Build Date: 627
[00:00:01]: SteamID: 76561198111555583
[00:00:01]: THREAD - started 'GAClient' (6040)
[00:00:01]: HttpClient::ClientThread::Main()
[00:00:01]: SteamApps()->BIsSubscribedApp( 282470 ) -- Subscribed!
[00:00:01]: SteamApps()->BIsDlcInstalled( 282470 ) -- Installed!
[00:00:01]: SteamApps()->BIsSubscribedApp( 393010 ) -- Subscribed!
[00:00:01]: SteamApps()->BIsDlcInstalled( 393010 ) -- Installed!
[00:00:01]: SteamApps()->BIsSubscribedApp( 712640 ) -- Subscribed!
[00:00:01]: SteamApps()->BIsDlcInstalled( 712640 ) -- Installed!
[00:00:01]: Cloud enabled: true
[00:00:01]:     Enabled app: true    Enabled account: true
[00:00:01]:     Num files: 26
[00:00:01]:     Quota used: 4.512 Mbytes / 200.000 Mbytes
[00:00:01]: HardwareStats:
  OS                        
    name                      Microsoft Windows 8.1
    version                   6.3.9600
    architecture              64-bit
    platformSpecific          SP 0.0
  CPU                       
    numCores                  2
    features                  SSE,SSE2,SSE3,SSSE3,SSE41,SSE42,AVX
    name                      Intel(R) Core(TM) i3-4350 CPU @ 3.60GHz
    manufacturer              GenuineIntel
    clockSpeed                3600
  RAM                       
    megsOfRam                 8192
  GPU                       
    name                      NVIDIA GeForce GTX 750 Ti
    driverDate                20190111000000.000000-000
    megsOfRam                 2048
    refreshRate               60
    videoModeDescription      1600 x 900 x 4294967296 colors
    driverVersion             25.21.14.1771

[00:00:01]: cGame::InitializeOnMainThread
[00:00:01]: WindowManager::Initialize
[00:00:01]: RestoreWindowPosition
[00:00:01]:    Saved Client Pos (243 x 39)
[00:00:01]:    Adjusted Window Pos (235 x 8)
[00:00:01]: EnsureWindowOnScreen
[00:00:01]:    All good.
[00:00:01]: GLInfo
[00:00:01]: ~~~~~~
[00:00:01]: THREAD - started 'WindowsInputManager' (6484)
[00:00:01]: GL_VENDOR: Google Inc.
[00:00:01]: GL_RENDERER: ANGLE (NVIDIA GeForce GTX 750 Ti)
[00:00:01]: GL_VERSION: OpenGL ES 2.0 (ANGLE 1.0.0.2249)
[00:00:01]: GL_SHADING_LANGUAGE_VERSION: OpenGL ES GLSL ES 1.00 (ANGLE 1.0.0.2249)
[00:00:01]: OpenGL extensions (19, 19):
[00:00:01]: GL_ANGLE_depth_texture
[00:00:01]: GL_ANGLE_framebuffer_blit
[00:00:01]: GL_ANGLE_framebuffer_multisample
[00:00:01]: GL_ANGLE_instanced_arrays
[00:00:01]: GL_ANGLE_pack_reverse_row_order
[00:00:01]: GL_ANGLE_texture_compression_dxt3
[00:00:01]: GL_ANGLE_texture_compression_dxt5
[00:00:01]: GL_ANGLE_texture_usage
[00:00:01]: GL_ANGLE_translated_shader_source
[00:00:01]: GL_EXT_read_format_bgra
[00:00:01]: GL_EXT_robustness
[00:00:01]: GL_EXT_texture_compression_dxt1
[00:00:01]: GL_EXT_texture_format_BGRA8888
[00:00:01]: GL_EXT_texture_storage
[00:00:01]: GL_OES_get_program_binary
[00:00:01]: GL_OES_packed_depth_stencil
[00:00:01]: GL_OES_rgb8_rgba8
[00:00:01]: GL_OES_standard_derivatives
[00:00:01]: GL_OES_texture_npot
[00:00:01]: GL_MAX_TEXTURE_SIZE = 16384
[00:00:01]: GL_MAX_TEXTURE_IMAGE_UNITS = 16
[00:00:01]: GL_MAX_RENDERBUFFER_SIZE = 16384
[00:00:01]: GL_MAX_VIEWPORT_DIMS = 16384, 16384
[00:00:01]: GL_MAX_VARYING_VECTORS = 10
[00:00:01]: GL_MAX_VERTEX_ATTRIBS = 16
[00:00:01]: GL_MAX_VERTEX_UNIFORM_VECTORS = 254
[00:00:01]: GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS = 4
[00:00:01]: GL_MAX_FRAGMENT_UNIFORM_VECTORS = 221
[00:00:01]: 4 compressed texture formats
[00:00:01]: texture format 0x83f0
[00:00:01]: texture format 0x83f1
[00:00:01]: texture format 0x83f2
[00:00:01]: texture format 0x83f3
[00:00:01]: FMOD VERSION: 00044464 (00044464)
[00:00:02]: cDontStarveGame::DoGameSpecificInitialize()
[00:00:02]: cGame::StartPlaying
 


Steps to Reproduce
Unfortunately I can't remember doing anything that would have caused this.

Status: Pending

This issue has not been confirmed by a developer yet.


  Report Bug
Sign in to follow this  


User Feedback


There are no comments to display.



Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now