Windows 10 Low FPS....12-13FPS


Xanokei
  • Pending

I am pretty sure this has been an Ongoing event as I have read many fixes for this and not many could find a proper fix for this

anyways, Game is runnning at 12-13FPS constantly, offline or solo at 24FPS

Windows 10
GTX 1070
i7-4770k 3.5GHz
32GB Ram
3TB HDD Black
256GB SSD 2x
 

 

58285672f1e8e_DontStarveTogetherFPScopy.jpg.054f48ebad6df5b1c9817b283358da03.jpg

client_log.txt

DxDiag.txt


Steps to Reproduce
Installed it and Opened the game.


User Feedback


Is the low fps intermittent or all the time?

When you are experiencing low fps, could you please preform a profile capture by entering the following into the debug console?

TheSim:Profile(1)

It is case sensitive. This will take one second to complete, then the file "profile.jason" will be saved out to your my documents/klei/DontStarveTogether directory. Could you attach this file here. Thanks.

  • Like 1

Share this comment


Link to comment
Share on other sites
Just now, ScottHansen said:

Here is fine. Thanks

Thanks a lot.

My specs:

OS: Windows 10 64-bit

OS version: 1607

Compilation number: 14393.447

16 GB RAM

Intel Core i7-3630QM CPU @ 2.40 GHz

Thanks a lot. Should I provide something else on top of that? I'm currently running ANR on this machine.

FPS drop rate.rar

Share this comment


Link to comment
Share on other sites
5 minutes ago, Arlesienne said:

Thanks a lot.

My specs:

 

  Reveal hidden contents

 

FPS drop rate.rar

Thanks for the quick response. Could you do me a favor and take the following attached file and replace your existing frontend.lua with it. You will need to restart DST after doing this.

To find the existing frontend.lua file, right click on DST in steam -> Properties -> Local Files tab -> Browse Local Files...
Then go into: data\scripts and replace the file.

frontend.lua

  • Like 1

Share this comment


Link to comment
Share on other sites
3 minutes ago, ScottHansen said:

Thanks for the quick response. Could you do me a favor and take the following attached file and replace your existing frontend.lua with it. You will need to restart DST after doing this.

To find the existing frontend.lua file, right click on DST in steam -> Properties -> Local Files tab -> Browse Local Files...
Then go into: data\scripts and replace the file.

frontend.lua

At once. Which folder should it go into - Scripts or Prefabs? Asking as the query for frontend.lua returns two locations.

C:\Program Files (x86)\Steam\steamapps\common\Don't Starve Together\data\scripts\prefabs
C:\Program Files (x86)\Steam\steamapps\common\Don't Starve Together\data\scripts

(I vote for Scripts as the file size matches.)
 

Edited by Arlesienne

Share this comment


Link to comment
Share on other sites
Just now, Arlesienne said:

At once. Which folder should it go into - Scripts or Prefabs? Asking as the query for frontend.lua returns two locations.

 

scripts

And in case it wasn't clear, run TheSim:Profile(1) again while you have a bad frame rate and attach the new profile.jason.

  • Like 1

Share this comment


Link to comment
Share on other sites
1 minute ago, ScottHansen said:

scripts

And in case it wasn't clear, run TheSim:Profile(1) again while you have a bad frame rate and attach the new profile.jason.

This is my .json file after overwriting frontend.lua (DST was closed all the time, launched again only after putting the new file into Scripts).

profile.json

Share this comment


Link to comment
Share on other sites
8 minutes ago, Arlesienne said:

This is my .json file after overwriting frontend.lua (DST was closed all the time, launched again only after putting the new file into Scripts).

profile.json

Thanks!

That confirms the source of this is exactly what I was hopping it wasn't (no point in getting into the details)...

@Arlesienne and @Xanokei By any chance are you downloading anything? maybe a windows update, BitTorrent, something in the background on a cell phone or tablet?

 

  • Like 1

Share this comment


Link to comment
Share on other sites
6 minutes ago, ScottHansen said:

Thanks!

That confirms the source of this is exactly what I was hopping it wasn't (no point in getting into the details)...

@Arlesienne and @Xanokei By any chance are you downloading anything? maybe a windows update, BitTorrent, something in the background on a cell phone or tablet?

 

No downloads. I'm using Firefox, the 64-bit version, to monitor the thread. To check on DST, Steam is running in the background. Plus a chargen for a tabletop RPG, but I don't think it should matter. It's freeware, I can show it. The issues did start without it though.

Share this comment


Link to comment
Share on other sites
1 minute ago, Arlesienne said:

No downloads. I'm using Firefox, the 64-bit version, to monitor the thread. To check on DST, Steam is running in the background. Plus a chargen for a tabletop RPG, but I don't think it should matter. It's freeware, I can show it. The issues did start without it though.

Sounds fair.

What screen were you on while you took that profile capture?

  • Like 1

Share this comment


Link to comment
Share on other sites

@Arlesienne  Could I get you to replace the following file with the one attached and then provide a new profile? This time please be in the main menu for least 10 seconds before capturing. (its fine if you've already restored your original frontend.lua)

C:\Program Files (x86)\Steam\steamapps\common\Don't Starve Together\data\scripts\data\scripts\widgets\onlinestatus.lua

onlinestatus.lua

Once this is done, please disable the mods you have, then Verify Integrity of Game Cache via steam and let me know if the problem goes a way (i'm guessing it wont but we gotta try this)

Edited by ScottHansen
wrong version of file
  • Like 1

Share this comment


Link to comment
Share on other sites
4 minutes ago, ScottHansen said:

@Arlesienne  Could I get you to replace the following file with the one attached and then provide a new profile? This time please be in the main menu for least 10 seconds before capturing. (its fine if you've already restored your original frontend.lua)

C:\Program Files (x86)\Steam\steamapps\common\Don't Starve Together\data\scripts\data\scripts\widgets\onlinestatus.lua

onlinestatus.lua

Once this is done, please disable the mods you have, then Verify Integrity of Game Cache via steam and let me know if the problem goes a way (i'm guessing it wont but we gotta try this)

For now, just launching the game with onlinestatus.lua attached was enough to give me my shiny 60 FPS back. However I am attaching the .json for testing. And, of course, I remain at your service for any testing. If I can contribute to help @Xanokei, I'd be delighted.

profile.json

Share this comment


Link to comment
Share on other sites
15 minutes ago, Arlesienne said:

For now, just launching the game with onlinestatus.lua attached was enough to give me my shiny 60 FPS back. However I am attaching the .json for testing. And, of course, I remain at your service for any testing. If I can contribute to help @Xanokei, I'd be delighted.

profile.json

And here lays the worst part of the problem, it just goes away after a while...(which is why I was asking about any active downloads) Thanks for all the help though! Now I've got something concrete to look into in my "spare time". Hopefully this leads somewhere.

  • Like 1

Share this comment


Link to comment
Share on other sites
29 minutes ago, ScottHansen said:

And here lays the worst part of the problem, it just goes away after a while...(which is why I was asking about any active downloads) Thanks for all the help though! Now I've got something concrete to look into in my "spare time". Hopefully this leads somewhere.

I can see how it goes. If there's any test I can run, just please let me know. I'd really like to help track this down. For a bit, I feared I got a virus in spite of my antivirus raging 24/7. Thank you so much again.

Share this comment


Link to comment
Share on other sites

I hope I am not hijacking this thread, but I seem to be having the exact same problem as OP.

I just brought DST and the game is running at around 12-13 fps. I tried running Don't Starve/RoG/Shipwreck and all of them seems to be running fine at 60 fps.

For specs, I have a similar:

Windows 10
GTX 1070
i7-4770k 3.5GHz
16GB Ram
250GB SSD

 

client_log.txt

DxDiag.txt

profile.json

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now