Wanda is Impossible to play as


HumanBean150
  • Closed

Recently bought Wanda, and every time I try to choose her in a self-hosted server (including a server set to public), I spawn in as wilson instead. Using c_despawn or the upgraded florid postern doesn't work either, with the same issue. I disabled all of my mods, both server and client, and made a new world with the default settings. I still wasn't able to play as Wanda. 

I have noticed that browsing games, I can join any public server as Wanda with no issue. 

No idea what's causing this, unfortunately. I've tried verifying my files through steam, and it didn't change anything.


Steps to Reproduce

Host a game, and select Wanda at the start. Obviously something else as well, but I can't figure it out.



User Feedback


please verify your game files and try again.

If the problem persists then please attach your client log and the server log for your world 
\Documents\Klei\DoNotStarveTogether\clien_log.txt
\Documents\Klei\DoNotStarveTogether\<your steam id>\Cluster_#\Master\server_log.txt

  • replace <your steam id> with your steamid
  • replace Cluster_# with the cluster folder for your world (you can click on the folder icon in the world select screen to get here)
  • Like 1
  • Thanks 2

Share this comment


Link to comment
Share on other sites
9 hours ago, ScottHansen said:

please verify your game files and try again.

If the problem persists then please attach your client log and the server log for your world 
\Documents\Klei\DoNotStarveTogether\clien_log.txt
\Documents\Klei\DoNotStarveTogether\<your steam id>\Cluster_#\Master\server_log.txt

  • replace <your steam id> with your steamid
  • replace Cluster_# with the cluster folder for your world (you can click on the folder icon in the world select screen to get here)

As I had said in the post, I had already verified the files at least 3 times. However, I just did it again after checking to make sure I still couldn't play Wanda, this time verifying them twice in a row, and it worked! Thanks for the help and sorry for the trouble. I guess it just needed a little more troubleshooting.

Share this comment


Link to comment
Share on other sites
On 9/13/2021 at 1:24 PM, ScottHansen said:

please verify your game files and try again.

If the problem persists then please attach your client log and the server log for your world 
\Documents\Klei\DoNotStarveTogether\clien_log.txt
\Documents\Klei\DoNotStarveTogether\<your steam id>\Cluster_#\Master\server_log.txt

  • replace <your steam id> with your steamid
  • replace Cluster_# with the cluster folder for your world (you can click on the folder icon in the world select screen to get here)

I hate to bring this up again, but I ran into the issue again. This time, I have the files attached. I definitely saw something in the server log about defaulting to Wilson. 

I made sure to disable my mods, and then verify the files multiple times, and then test again on a brand new world. It had the same result, and that is the world that I attached the files from.

Sorry for the trouble!

server_log_troubleshoot.txt client_log_troubleshoot.txt

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now