Vanilla gamehosting do not work (ALL mods disabled)


MasterOfSurvival
  • Closed

Hello DST Team,

If I want to host a new, vanilla game DST stops to work and I get the error: 

#[string "scripts/map/level.lua"]:103 bad argument #1 to "pairs" (table expected, got nil) ...

I will send more Information if you want fix this error. 

Thanks in advance

client_log.txt


Steps to Reproduce
I used a custom present (not to extrem like: Trees | More)


User Feedback


1 hour ago, jantonio said:

have you played with mods on the server before hand?

No, but I know what you meant there

 

Edited by MasterOfSurvival

Share this comment


Link to comment
Share on other sites
31 minutes ago, jantonio said:

do you have the client mod, "too many items"?

I deactivated ALL mods including the client mods like always on status.

And no I have not.

 

Edited by MasterOfSurvival

Share this comment


Link to comment
Share on other sites

Maybe you can reproduce the error if you have the same modified present

How can I copy the present?

Edited by MasterOfSurvival
More information/ No spam

Share this comment


Link to comment
Share on other sites

@MasterOfSurvival

I'm looking at the preset data from the log files. It appears this preset might have been made while a mod was enabled. Could that be the case?

If you create a world using the default preset, do you still get this error?

Share this comment


Link to comment
Share on other sites
Just now, ScottHansen said:

@MasterOfSurvival

I'm looking at the preset data from the log files. It appears this preset might have been made while a mod was enabled. Could that be the case?

If you create a world using the default preset, do you still get this error?

I have several world edit mods but they were all turned off. Also I reinstalled DST

Share this comment


Link to comment
Share on other sites

Thanks for trying that.

When you last saved "Custom Preset 1", did you have mods enabled? That preset is showing a world layout task that does not exist in "vanilla" DST.

Share this comment


Link to comment
Share on other sites

Ah I solved the problem by accident ^^ I figured out if you use WorldGen mods to create a present and try to use the present the game crashes even if the menu shows no more moded Worldgen and everything seems normal (Settings).

 

Share this comment


Link to comment
Share on other sites
4 minutes ago, ScottHansen said:

Thanks for trying that.

When you last saved "Custom Preset 1", did you have mods enabled? That preset is showing a world layout task that does not exist in "vanilla" DST.

Yeah. I am sorry but I just could not find out what I did wrong:confused:. Thank you so much :) I love your game so much and was really sad it was broken. 

 

Edited by MasterOfSurvival

Share this comment


Link to comment
Share on other sites

@MasterOfSurvival Np, I'm glad it got sorted out.

If you do not have a bunch of other custom presets and not modified your controller layout or saved a bunch of preferred character skins layouts, then i'd suggest deleting Documents\Klei\DoNotStarveTogether\client_save\client_save\profile

That will remove the bad custom preset so you don't use it again.
I've added cleaning this up to my task list so others don't fall into the same situation.

 

  • Like 1

Share this comment


Link to comment
Share on other sites
58 minutes ago, ScottHansen said:

@MasterOfSurvival Np, I'm glad it got sorted out.

If you do not have a bunch of other custom presets and not modified your controller layout or saved a bunch of preferred character skins layouts, then i'd suggest deleting Documents\Klei\DoNotStarveTogether\client_save\client_save\profile

That will remove the bad custom preset so you don't use it again.
I've added cleaning this up to my task list so others don't fall into the same situation.

 

I could simply costumize the default one and overwrite the broken one.

Share this comment


Link to comment
Share on other sites
1 minute ago, MasterOfSurvival said:

I could simply costumize the default one and overwrite the broken one.

But you have to use the default one otherwise you get the broken one again, so its no about overwriting it (It could be happening you just have 2 broken presents and overwrite the broken1 with the broken2. = same error) 

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now