Jump to content

[*Shipwrecked* - the option to post in that bugtracking section is grayed out] "dontstarve.exe stopped working" crash when generating a SW world (RoG/Vanilla load and play fine)

  • Pending

I've been playing RoG for a couple of hundred game-days, and just installed SW. Generating a SW world causes an '.exe stopped working' crash (right after the blank screen with "Loading..." in the bottom left corner appears at the end). This is with the GOG version, build 189434, unmodded, after reinstalling a few times - including deleting the settings/saves and game folders.

From other posts, I assume the Intel HD 4000 graphics chip is the problem, though RoG runs smoothly, and hasn't ever crashed or glitched. I've made sure the drivers are up to date and tried lowering the resolutions and graphics options. I also tried adding '-alternate_gc' to the "Target" field in the game shortcut properties menu, and took a shot in the dark and tried adding 'use_alternate_gc = true' under [MISC] in the settings.ini file.

The integrated graphics is obviously kind of marginal, but again, RoG runs at a smooth, relatively high fps (unnoticeable most of the time, occasionally gets choppy if a lot is going on, but never close to unplayably). I've also played DS with a good card, and I was surprised at how well it runs with just the integrated chip, which is why I wonder if there's a way to get SW working.

Thanks for any help.


User Feedback

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...