Sign in to follow this  

Retrofitting failed for Waterlogged update


spider312
  • Fixed

Hi,

On a dedicated server, with some mods (notably the Legion mod), i can't get retrofitting done, server log says :

[00:00:18]: Retrofitting for Return Of Them: Watterlogged - Adding Waterlog biome 1
[00:00:18]:    0 candidtate locations
[00:00:18]:    13 candidtate locations
[00:00:18]: Retrofitting for Return Of Them: Waterlogged - Failed to add Waterlog setpiece 1 to the world!
[00:00:18]: Retrofitting for Return Of Them: Watterlogged - Adding Waterlog biome 2
[00:00:18]:    0 candidtate locations
[00:00:18]:    13 candidtate locations
[00:00:18]: Retrofitting for Return Of Them: Waterlogged - Failed to add Waterlog setpiece 2 to the world!
[00:00:18]: Retrofitting for Return Of Them: Watterlogged - Adding Waterlog biome 3
[00:00:18]:    0 candidtate locations
[00:00:18]:    13 candidtate locations
[00:00:18]: Retrofitting for Return Of Them: Waterlogged - Failed to add Waterlog setpiece 3 to the world!
[00:00:18]: Loading Nav Grid
[00:00:18]: World generated on build 393281 with save version: nil, using seed: 1581461818

When i check existence of Waterlogged specific structure (c_countprefabs("watertree_pillar")) it says 0

I tried to load this game directly into client, disabling mod Legion and others that can affect generation (Force triple mac tusk, Setpiece config), but still the same

It's a pretty old game (2800 days)

Is there anything i can try to get retrofitting done for this update ?

Thanks in advance


Steps to Reproduce

I just did my update procedure like i always did :

Stop server

Update server bin via steamcmd

Started server

Sign in to follow this  


User Feedback


A developer has marked this issue as fixed. This means that the issue has been addressed in the current development build and will likely be in the next update.

I loaded an old backup from before applying the Celestial Champion upgrade (200 ingame days ago), the new biome was correctly generated

Share this comment


Link to comment
Share on other sites

Well, i don't consider issue as solved, i just added information in case it helps. 200 days is more than 25h of base building, boss fighting, etc.

Share this comment


Link to comment
Share on other sites
On 8/20/2021 at 7:52 PM, spider312 said:

Well, i don't consider issue as solved, i just added information in case it helps. 200 days is more than 25h of base building, boss fighting, etc.

And why do you not consider the issue solved?

Share this comment


Link to comment
Share on other sites

Oh, something changed in the game ? Now when i load the game in the client the new biome is generated

I just thought my addition comment was the reason why you marked the issue as solved, my bad :)

Well now i consider the issue as solved :) Thank you very much !

Edited by spider312

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now