PS3 controller shows up as Xbox360 controller on Mac

  • Pending

Hi, I recently got a PS3 controller and tried playing DST on my Mac. When I start up the game, I get the message saying a controller was detected, but all the keys show up as A, B, X, and Y, and in the options Menu, the Input type shows Xbox360, instead of Generic controller. Normally this wouldn't cause too much inconvenience, except that whenever I try to change any of the key bindings, it automatically binds that key to the left trigger (LT), even though the left trigger isn't being pressed. Scrolling through the inventory is also bound to LT by default, which makes the game unplayable as the inventory keeps scrolling to the right. This doesn't happen with any other game I've tested.

I have tried playing DST with the same controller on PC, and it works just fine.

Steps to Reproduce
I'm using a PS3 wired controller (DG-8186) and am running Mac OSX El Capitan (10.11.5) on the latest version of the game (v181387).

User Feedback

There are no comments to display.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now