No ground/walk on water

  • Closed

I've made a post about this before, but the answer did not solve my issue.

When I join ANY server on Don't Starve Together (modded or unmodded, whether I have mods installed or not) the ground is broken. It's either all black, or my character model is walking on water. Sometimes I'm walking on land, but trees, berry bushes, twigs, etc. spawn in the water.

I've tried verifying the game cache, I've tried uninstalling and reinstalling the game. I've tried uninstalling and reinstalling Steam itself. I've cleaned up my computer to make sure it wasn't something wrong with the registry.

There is something broken with the game, and no one will help me. I just get filed under "cannot reproduce" and get no service. I paid money for this game and it doesn't work anymore!

It worked about 3 months ago or so, but randomly broke.

Steps to Reproduce
I join a server and it's broken.

User Feedback

Hey @DoopSnogg, have you tried to set the game to run as administrator yet? Go to the game files in this location Steam\steamapps\common\Don't Starve Together Beta\bin and right click the .exe file called dontstarve_steam then click Properties. Under compatibility enable the Run this program as administrator. Click Appy then Ok. Then start up the game from the steam client then check if the issue still occurs. You can also probably try and delete the DoNotStarveTogether folder in Documents\Klei for a fresh start. Be sure the game is closed before you do any of these. 

If the issue still persists, can you attach the client_log.txt under Documents\Klei\DoNotStarveTogether in your next reply.

Edited by Zillvr

Share this comment

Link to comment
Share on other sites

I do not have a Klei folder in my documents folder...

Could that be the problem?

Also, I feel I should add that if I start my own server, it works perfectly. It's only when I'm joining other people's servers, modded or not. In fact, people who's games work in other servers break when joining mine.

I don't understand why my game is so broken though.


Edited by DoopSnogg

Share this comment

Link to comment
Share on other sites

@DoopSnogg So have you enabled the Run this program as administrator yet? (you didn't confirm if you did or not) Then running the game again from steam? If no Klei folder exists then this is most likely due to the game not having read/write access to your documents folder. Your PC account should have administrative access. Try the method in this Klei Article if enabling Run this program as administrator doesn't work.

Share this comment

Link to comment
Share on other sites

You can go ahead and delete this thread. I created a new user account on my computer and the game started working, so I guess there was something wrong with my computer.

Share this comment

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now