Jump to content

Massive input delay during boss fights

  • Pending

So, I am on my second winter now and am in the process of fighting Klaus, I'm more than well equipped to beat him and know the kiting pattern off by heart at this point. However...about a third of the way into the fight (more or less where he summons krampuses) I start to get an absurd amount of input lag, to the point where the game is virtually unplayable. I suspect it might be server lag, which frustrates me because I'm playing alone and as far as I know there is zero way to play offline. What makes it even more frustrating is that the game runs fine when I first load up the world, the start of the boss is an absolute breeze. Does anyone have any suggestions as how I can fix this?

Steps to Reproduce
Fight klaus on local or online play when hosting a server

User Feedback

Here's a few that could potentially resolve your issue.

First off, set Lag Compensation to None (Settings -> Lag Compensation -> None). Lag Compensations places a delay on your inputs after predicting what you're going to do. You don't need lag compensation on low ping servers and especially not when you host your own world. Will it address the large input lag spikes? I would say Lag Compensation addresses general lag and the 2nd point more so your lag spikes.

Secondly, what mods are you using, if any? Some mods are notorious for lag, (I'm pointing my fingers at you, Display Food Values). The more mods you have on, the more you risk in-game issues or lag that occurs because those mods exist. Disable all your mods and then re-enable them individually to see what's causing the lag. 

There could also be an issue with your graphics card, though I highly doubt it and can only give advice if its an Nvidia graphics card.

If it's Nvidia, right click on the desktop, go to Nvidia Control Panel -> Manage 3D Settings -> Program Settings -> Don't Starve(dontstarve_steam.exe). Choose the following settings.

Select the preferred graphics processor: High performance NVIDIA processor

Power management mode: Prefer maximum performance

Threaded optimization: ON

Triple buffering: Off

Vertical Sync: Off


Share this comment

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...